[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Minios-devel] [UNIKRAFT PATCH v5 00/15] import bitmaps from FreeBSD



Changes since v1:

 - resplit patches for more convinent review. I did it for myself just
   to separate important changes from spaces noise. But small change
   by small change it grew into v2.

 - add prefix "uk_" to bitcount* functions

 - use non-ordered versions of ukarch_(set|clr|test)_bit when ordered
   version is not required

 - use ukarch_test_and_(set|clr)_bit_sync functions for
   test_and_(set|clear)_bit instead of reimplementing them

Changes since v2:

 - massive function renaming - add uk_ prefix to all functions/macro

 - remove ffz - it is not used anywhere sofar. Even if it is needed it
   belongs to uk/arch/atomic.h with the prefixt ukarch_. Which is a
   bit ugly, because it does not follow the convention used in this
   series: linux api functions with the uk_ prefix.

   Anyways, ukarch_ffs(~word) is not much longer then ukarch_ffz(word)

 - add assertion for the undefined behaviour of ffs-functions if
   argument is zero

Changes since v3:
 Only commits order and commits messages have changed since v3:
 
 - squash prefixing bitmap.h and bitops.h (for seldom used functions)

 - make major prefixing patch appearing earlier in the series

Changes since v4:

 - add comments about __set_bit and set_bit

 - remove test_bit temporarily

 - remove the assertion for the undefined behaviour of ffs-functions if
   argument is zero (back to v2 state)

Costin Lupu (8):
  include/uk/arch: Add ukarch_ffs, ukarch_fls, ukarch_flsl functions for
    x86_64
  lib/nolibc: add sys/param.h header
  include/uk: import bitcount.h
  include/uk: import bitops.h and bitmap.h from FreeBSD
  include/uk: bitmap, bitopts - fix spaces issues
  include/uk: bitmap, bitops - fix return is not a function
  include/uk: use ukarch_ffs func family in bitopts.h
  include/uk: adapt bitops.h, bitmap.h for Unikraft

Yuri Volchkov (7):
  include/uk: bitopts.h - remove already existing functions
  include/uk: prefix functions in bitmap.h and bitopts.h
  include/uk: add prefix to BITS_PER_LONG
  include/uk: add prefix to BITMAP_(FIRST|LAST)_WORD_MASK
  include/uk: add prefix to BITS_TO_LONG and BIT_WORD
  include/uk: add prefix to hweight* functions
  include/uk: rename linux_reg_op to __uk_bitops_reg_op

 include/uk/arch/x86/x86_64/atomic.h |  46 +++-
 include/uk/bitcount.h               |  91 ++++++++
 include/uk/bitmap.h                 | 292 +++++++++++++++++++++++
 include/uk/bitops.h                 | 347 ++++++++++++++++++++++++++++
 lib/nolibc/include/sys/param.h      |  52 +++++
 lib/nolibc/include/sys/select.h     |   7 +-
 6 files changed, 828 insertions(+), 7 deletions(-)
 create mode 100644 include/uk/bitcount.h
 create mode 100644 include/uk/bitmap.h
 create mode 100644 include/uk/bitops.h
 create mode 100644 lib/nolibc/include/sys/param.h

-- 
2.18.0


_______________________________________________
Minios-devel mailing list
Minios-devel@xxxxxxxxxxxxxxxxxxxx
https://lists.xenproject.org/mailman/listinfo/minios-devel

 


Rackspace

Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.