[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Minios-devel] [UNIKRAFT/MUSL PATCH V2 12/28] Use uk/bits/syscall_nrs.h instead of musl internal bits/syscall.h



Reviewed-by: Simon Kuenzer <simon.kuenzer@xxxxxxxxx>

On 29.01.20 22:18, Gaulthier Gain wrote:
This patch updates Makefile.uk and include/sys/syscall.h in order to
avoid generating a clone of syscall_nrs.h which is defined within
Unikraft.

Signed-off-by: Gaulthier Gain <gaulthier.gain@xxxxxxxxx>
---
  Makefile.uk                                |  9 --------
  patches/0006-Use-uk_bits_syscall_nrs.patch | 26 ++++++++++++++++++++++
  2 files changed, 26 insertions(+), 9 deletions(-)
  create mode 100644 patches/0006-Use-uk_bits_syscall_nrs.patch

diff --git a/Makefile.uk b/Makefile.uk
index a0a843c..9657bb7 100644
--- a/Makefile.uk
+++ b/Makefile.uk
@@ -79,13 +79,6 @@ $(LIBMUSL)/arch/$(ARCH)/bits/alltypes.h: 
$(LIBMUSL_BUILD)/.patched
                $(LIBMUSL)/include/alltypes.h.in > $@ && \
                $(TOUCH) $@)
-# generate syscall.h
-$(LIBMUSL)/arch/$(ARCH)/bits/syscall.h: 
$(LIBMUSL)/arch/$(ARCH)/bits/syscall.h.in
-       $(call verbose_cmd,CONFIGURE,libmusl: $(notdir $@),\
-               cp $< $@ && \
-               sed -n -e s/__NR_/SYS_/p < $< >> $@ && \
-               $(TOUCH) $@)
-
  # generate version.h
  $(LIBMUSL)/src/internal/version.h:
        $(call verbose_cmd,CONFIGURE,libmusl: $(notdir $@),\
@@ -93,11 +86,9 @@ $(LIBMUSL)/src/internal/version.h:
                $(TOUCH) $@)
UK_PREPARE += $(LIBMUSL)/arch/$(ARCH)/bits/alltypes.h
-UK_PREPARE += $(LIBMUSL)/arch/$(ARCH)/bits/syscall.h
  UK_PREPARE += $(LIBMUSL)/src/internal/version.h
LIBMUSL_CLEAN += $(LIBMUSL)/arch/$(ARCH)/bits/alltypes.h
-LIBMUSL_CLEAN += $(LIBMUSL)/arch/$(ARCH)/bits/syscall.h
  LIBMUSL_CLEAN += $(LIBMUSL)/src/internal/version.h
################################################################################
diff --git a/patches/0006-Use-uk_bits_syscall_nrs.patch 
b/patches/0006-Use-uk_bits_syscall_nrs.patch
new file mode 100644
index 0000000..6d1fdf5
--- /dev/null
+++ b/patches/0006-Use-uk_bits_syscall_nrs.patch
@@ -0,0 +1,26 @@
+From 0707c3af258a7859bd91e3efa468d39a5a151a3f Mon Sep 17 00:00:00 2001
+From: Gaulthier Gain <gaulthier.gain@xxxxxxxxx>
+Date: Sat, 25 Jan 2020 14:18:41 +0100
+Subject: [PATCH] Use uk/bits/syscall_nrs.h instead of musl internal
+ bits/syscall.h
+
+Signed-off-by: Gaulthier Gain <gaulthier.gain@xxxxxxxxx>
+---
+ include/sys/syscall.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/sys/syscall.h b/include/sys/syscall.h
+index 24987dd..918de59 100644
+--- a/include/sys/syscall.h
++++ b/include/sys/syscall.h
+@@ -1,6 +1,6 @@
+ #ifndef _SYS_SYSCALL_H
+ #define _SYS_SYSCALL_H
+
+-#include <bits/syscall.h>
++#include <uk/bits/syscall_nrs.h>
+
+ #endif
+--
+2.20.1
+


_______________________________________________
Minios-devel mailing list
Minios-devel@xxxxxxxxxxxxxxxxxxxx
https://lists.xenproject.org/mailman/listinfo/minios-devel

 


Rackspace

Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.