[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[MirageOS-devel] require opam 1.2 in mirage?

  • To: mirageos-devel <mirageos-devel@xxxxxxxxxxxxxxxxxxxx>
  • From: Anil Madhavapeddy <anil@xxxxxxxxxx>
  • Date: Tue, 27 Jan 2015 00:56:11 +0000
  • Delivery-date: Tue, 27 Jan 2015 00:56:23 +0000
  • List-id: Developer list for MirageOS <mirageos-devel.lists.xenproject.org>

A few reasons why we should probably require OPAM 1.2 in Mirage now:

- The development workflow is far nicer.

- In `is-mirage-broken`, there's an oddly non-deterministic failure where an 
older version of cohttp is sometimes installed (see 
https://github.com/mirage/is-mirage-broken/tree/master/logs and the 
mirage-skeleton failures).  OPAM 1.2 lets us specify `opam install cohttp>0.14` 
which will force the latest versions.

- OPAM 1.1 is in a broken state on Ubuntu 14.10, so we can segway people into 
using the PPA with OPAM 1.2 instead.

We do need a patch to test the OPAM version in the Mirage tool before doing 
this though.  

MirageOS-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.