[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[MirageOS-devel] Getting started documentation issues

I'm tinkering with some automation to make getting started with Mirage
easier and ran into a few issues I thought I'd mention.

While following the docs at: http://openmirage.org/wiki/install

1. The list of supported operating systems (ArchLinux, Debian Wheezy,
Ubuntu Precise/Lucid/Raring/Saucy, CentOS 6.4 and MacOS X 10.8 and
10.9) appears to contain older systems. Is this still up-to-date?

2. The docs state: Note that you require OPAM 1.1 or greater to use
with Mirage. Some distribution packages provide earlier versions.
Running opam init with 1.1.1 on Ubuntu Trusty (14.04) results in the
following error:

[ERROR] Your version of OPAM (1.1.1) is not recent enough to read
~/.opam/repo/default/packages/websocket/websocket.0.9.2/opam. Upgrade
OPAM to a more recent version (at least 1.2) to read this file
[WARNING] Errors while parsing websocket.0.9.2 OPAM file, skipping.

3. Information on https://github.com/ocaml/opam/wiki/Quick_Install is
also out of date regarding the above. The PPA mentioned also has
Trusty packages although this isn't mentioned.

I should have a Puppet (disclaimer I work for Puppet Labs in
Cambridge, but this is a pet project rather than work) module released
soon that helps build an Ubuntu Trusty box for building mirage

My vague plan from there is to turn that into zero or more of: a local
compile service, a test harness for testing unikernel
compilation/execution and/or a remote compile service.

I'll post here when I have code to show, but if anyone is particularly
interested let me know. I'm a newbie when it comes to ocaml but I've
lots of experience with automation and infrastructure.


Gareth Rushgrove


MirageOS-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.