[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [MirageOS-devel] Problem installing mirage on FreeBSD

By the way the workaround worked fantastically... Glad to be exploring
MirageOS on my favorite traditional OS :-)

Carl Dong
"I fight for the users"

On Sat, Jul 11, 2015, at 01:29 PM, Anil Madhavapeddy wrote:
> On 11 Jul 2015, at 21:18, Carl Dong <dongcarl@xxxxxxxxxxxx> wrote:
> > 
> > Hi all,
> > 
> > I started with a fresh install of FreeBSD 10.1 Release and installed
> > opam from FreeBSD's ports collection. I did `opam init` and ran `eval
> > (opam config env)` (I'm on fish shell). Then I ran `opam install mirage`
> > which resulted in the following log: http://pastebin.com/Zn5mQkvv
> > Any clue? Should I be asking in another mailing list?
> Looks like a bug in the FreeBSD port of OPAM -- it should also depend
> on the "ocaml-camlp4" port as well as OCaml.  Try pkg_add'ing the
> ocaml-camlp4 package and retrying the installation.
> Alternatively, you can workaround this by "opam switch 4.02.2" and
> it will compile a local version of camlp4 and let you continue.
> -anil

MirageOS-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.