[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-API] Regarding Project Kronos: Problems faced and feedbacks

  • To: "xen-api@xxxxxxxxxxxxxxxxxxx" <xen-api@xxxxxxxxxxxxxxxxxxx>
  • From: Deepak Garg <deepak.garg@xxxxxxxxxx>
  • Date: Tue, 27 Dec 2011 10:42:59 +0530
  • Accept-language: en-US
  • Acceptlanguage: en-US
  • Delivery-date: Tue, 03 Jan 2012 07:09:04 +0000
  • List-id: Discussion of API issues surrounding Xen <xen-api.lists.xensource.com>
  • Thread-index: AQHMxFa16ieLtjU3nkWvh7NU8UnDYw==
  • Thread-topic: Regarding Project Kronos: Problems faced and feedbacks

Hi All,

Greetings and warm Wishes for the day !

I am Deepak Garg, an Openstack Developer working for Citrix R&D, Bengaluru, 

This email is meant for the Project Kronos developers. If this is not the right 
mailing list, I will
really be thankful if you would forward it to them or reply me back with the 
correct mailing list id.

I was amazed when I came across the Project Kronos wiki because that would make 
my life easier with 
Openstack development and deployment.
As per the wiki, I deployed an Ubuntu Oneiric 64 bit desktop and followed the 
steps in the wiki:
Link: http://wiki.xen.org/wiki/XCP_toolstack_on_a_Debian-based_distribution

Problems and feedbacks:
a. After adding the repos to /etc/apt/sources.list mentioned in the wiki, I 
tried apt-get update. I get 
        the following error:
   "W: GPG error: http://ppa.launchpad.net oneiric Release: The following 
signatures couldn't be verified because the public key is not available: 
NO_PUBKEY 79B578FB9273A937".
        But the xcp toolstack was installed properly after that.

b. After setting up xenbr0, I had setup the xensource inventory in 
/etc/xcp/xensource-inventory as per
        the wiki. But there was already a /etc/xcp/inventory file with half of 
the settings, so I had updated that too. 
So, please update the wiki if 'xensource-inventory' is not the right filename.

c. The cmd given in wiki "service xapi status" doesn't seem to be working. 
Instead the correct cmd seems
to be "service xcp-xapi status" which works as desired. So I have updated the 
wiki with the new cmd.

d. The actual problem I am facing ( and unresolved ) is with the following cmd 
 link:  http://wiki.xen.org/wiki/Using_XCP_-_preparing_the_toolstack
 "xe sr-create type=ext device-config:device=/dev/sda10 name-label=ext"
I get the error:  "The SR could not be connected because the driver was not 
driver: ext"
 (I have /dev/sda10 as a logical partition formatted with ext3)

I get the above error even when I try to connect an NFS or LVM SR. I tried the 
above cmd with additional
optional parameters but it wasn't fruitful.
I tried to google around but couldn't find anything helpful. I have 
"xcp-storage-managers" package installed.
I found some references in some forums about xapi-sm but I am afraid  I 
couldn't find any package with that name.

I will be obliged if anyone can help me around this. 
Also, I would love to try and experiment with new features you add to the 
Please keep me noted and I will update the wiki with all the new information 
and work arounds.

My env configuration:  Linux deepak-xcp 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 
7 14:56:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Let me know if you need more information.

Deepak Garg,
Software Developer,
Citrix R&D, India

Email: deepak.garg@xxxxxxxxxx

xen-api mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.