[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-API] xcp and minimum memory

  • To: xen-api@xxxxxxxxxxxxx
  • From: Lyn Amery <lyn@xxxxxxxxxxxxxxxxxxxx>
  • Date: Fri, 28 Sep 2012 13:40:19 +0800 (WST)
  • Delivery-date: Fri, 28 Sep 2012 05:40:53 +0000
  • List-id: User and development list for XCP and XAPI <xen-api.lists.xen.org>


I've installed xcp (xcp-xapi) on Ubuntu 12.04 - installed, but have gotten no further.  What's stopped me dead in my tracks is that Xen appears to grab most of my 6GB of memory - well, *something does* - leaving only 1GB for me to run my desktop on.  Very slow and painful to use.  (It would be ideal to run this on a test server, but nothing is available.)

First, do I understand correctly that "dom0" is just the host system?  In other words, when I boot the Xen kernel, that's dom0, yes?

Here's what I've tried up to this point.

Edited /etc/default/grub


also tried


... followed by update-grub command.

Edited /etc/xen/xend-config.sxp


  xend-config.sxp:(dom0-min-mem 2048)

  (enable-dom0-ballooning no)

All mods followed by reboots, of course.  None seems to make any difference.  The performance monitor application and "free" command show just under 1GB available when booted under the Xen kernel, 6BG when booted under normal Ubuntu.

Xen reports the proper memory stats:

# xe host-list params=all | grep memory

  memory-overhead ( RO): 83017728

  memory-total ( RO): 6372888576

  memory-free ( RO): 5120520192

  memory-free-computed ( RO): <expensive field>

Have I missed some basic concept somewhere?  Anyone have similar problems?



Lyn Amery
Gaia Resources
p +61 8 9227 7309
w www.gaiaresources.com.au
e lyn@xxxxxxxxxxxxxxxxxxxx

Xen-api mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.