[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-API] XCP 1.6, create ISO shared storage on NFS using CLI - "missing the location parameter"


I'm trying to add a shared ISO storage over NFS to my pool, using the CLI, and get a error that suggests something is wrong with my syntax. The NFS server works fine, as far as I can test it. I'm able to add the shared ISO storage using XenCenter GUI.

Using XenServer 6.1 documentation [1] as reference, I run:
xe sr-create name-label="NFS ISO library" \
  type=iso content-type=iso  shared=true\

And get:
Error parameters: , The request is missing the location parameter,

(Those whitespace around commas may indicate that some parameters are not parsed correctly?)

In the same reference document, I found a mention of a slightly different syntax [2], normally used to create a NFS VHD storage. I tested it, modifying the type= and content-type=:
xe sr-create name-label="NFS ISO library" \
  type=iso content-type=iso shared=true \
  device-config:server=nfs-server-hostname \

...and got the same error.

Even if I try to bind the SR to a specific host, it's the same:
xe sr-create name-label="NFS ISO library" \
  host-uuid=`xe host-list name-label=xcp-node24 --minimal` \
  type=iso content-type=iso \

...same error.

I must add, the CLI works great when I create a NFS VHD:
xe sr-create name-label="NFS virtual disk storage" \
  type=nfs content-type=user shared=true \
  device-config:server=nfs-server-hostname \

Please advice, what am I missing?

Thank you.

[1] http://docs.vmd.citrix.com/XenServer/6.1.0/1.0/en_gb/reference.html#id891311 [2] http://docs.vmd.citrix.com/XenServer/6.1.0/1.0/en_gb/reference.html#id894664

Alexandre Kouznetsov

Xen-api mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.