[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-API] [Xen-users] Error Starting Virtual Machines on XCP

  • To: Amit More <amore@xxxxxxxxx>
  • From: James Bulpin <James.Bulpin@xxxxxxxxxxxxx>
  • Date: Fri, 22 Feb 2013 17:52:53 +0000
  • Accept-language: en-US
  • Acceptlanguage: en-US
  • Cc: "xen-api@xxxxxxxxxxxxx" <xen-api@xxxxxxxxxxxxx>
  • Delivery-date: Fri, 22 Feb 2013 17:52:59 +0000
  • List-id: User and development list for XCP and XAPI <xen-api.lists.xen.org>
  • Thread-index: Ac4Q2CUVAc++kvZORyuz7gLDvCbMzgATNh8A
  • Thread-topic: [Xen-API] [Xen-users] Error Starting Virtual Machines on XCP

> On Thu, 2013-02-21 at 19:34 +0000, Amit More wrote:
> > Hi All,
> >
> > I have XCP 1.1.0-50674c running on a Dell PowerEdge 2950 system with
> a
> > couple of virtual machines running on it. The virtual machines that
> > are currently running are working fine, however I cannot start the
> > virtual machines are are currently powered off. The error in the
> > XenCenter (version 6) logs says "Internal error:
> > Device.PV_Vnc.Failed_to_start". I also tried to start the virtual
> > machine using xe command but to no avail. I have tried to start
> > different virtual machines on the same XCP hosts, and I get the same
> > error (mentioned above) every time I try to start a virtual machine.
> > The XCP system tries to start the virtual machine for about 20-25
> > minutes before giving up.
> >
> > I haven't added or removed any hardware from the Dell PowerEdge
> system
> > on which XCP is running. The only modifications to the virtual
> > machines were adding (and removing) network interfaces. I also
> suspect
> > that if I take the running virtual machines down, I won't be able to
> > bring them back up again.
> >
> > I searched the internet for answers, but couldn't find any convincing
> > ones. Any help would be greatly appreciated.

That probably means vncterm didn't start for some reason. If you've not
changed anything then it might be some kind of resource exhaustion such
as domain0 disk space or some process's FD limit has been reached. I
suggest having a poke around dom0 and looking for unusual things like
this. Otherwise do a trawl of the logs on the server to see if there are
any obvious errors with vncterm mentioned.


Xen-api mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.