[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-API] xe vm-list Error: Connection refused (calling connect )

I have a theory that our issues were due to some equipment faults on our storage network. We are using iscsi over multipathed 10gbe for our storage network and had a failure of our storage network previous to the issue, although it was intermittent. Our 10gbe switch was suffering from an issue and has since been replaced. What are you using for your storage backend? Are you running this on a stand alone system? We are running ours in a pool. We had some issues with inside-vm database corruption as well. We have not seen this issue or the previous error since correcting the storage network.

Yes, please upload the log if possible, I would like to look through it if that is acceptable.


On 3/7/13 10:10 PM, claytonly wrote:
Hi, Grodowitz
ÂÂÂÂ Thank you for your response. The environment is not a fresh one, it works well. What has happened on my xcp platform? should I upload the complete xcp-xapi.log ?


åääïNathan Grodowitz <nathangrodowitz@xxxxxxxxx>
äéïRe: [Xen-API] xe vm-list Error: Connection refused (calling connect )
æääï"æä è"<claytonly@xxxxxxx>

I have seen this same issue on a freshly installed xcp 1.6 cluster/pool. This required a fresh install on one node in the pool and a back on one, which showed and repaired the disc corruption. We also had some in VM corruption resulting in us reimporting all VMs that were running at the time.

I would be glad to upload any pertinent log files for analysis. I am very interested in digging into this issue.

On Mar 7, 2013 8:53 AM, "æäè" <claytonly@xxxxxxx> wrote:

-------- Forwarding messages --------
From: "æäè" <claytonly@xxxxxxx>
Date: 2013-03-07 22:40:20
To: xen-api-request <xen-api-request@xxxxxxxxxxxxx>
Subject: xeÂvm-listÂError:ÂConnectionÂrefusedÂ(callingÂconnectÂ)
ÂÂÂÂÂÂÂÂ I install xcp-api on ubuntu 12.04 64 bit. I got a problem that when i run 'xe vm-list' afte restart guest vm, it return xe vm-list
Error: Connection refused (calling connect ). I find that xcp-api wasn't running. When I tried to start xcp-xapi
by '/etc/init.d/xcp-api restart', it returns Error: Connection refused (calling connect ) again.why is that? the attachment is the part of xcp-xap.log.
Thank you !


Xen-api mailing list

Xen-api mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.