[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-API] VM won't start after a shutdown

  • To: "xen-api@xxxxxxxxxxxxx" <xen-api@xxxxxxxxxxxxx>
  • From: Tom Luong <tom@xxxxxxxxxxxxxxx>
  • Date: Fri, 8 Mar 2013 01:57:07 -0800
  • Accept-language: en-US
  • Acceptlanguage: en-US
  • Delivery-date: Fri, 08 Mar 2013 09:57:45 +0000
  • List-id: User and development list for XCP and XAPI <xen-api.lists.xen.org>
  • Thread-index: Ac4b4AtB+9fXcGADTymrykneDCcObw==
  • Thread-topic: VM won't start after a shutdown


I was in the process of moving a VM from a XCP 1.1 to XCP 1.6 host.  I shut down the VM and exported it and then imported it to the new host.  Everything went fine until I try to boot the VM.  Any help or advise is much appreciated.


Here’s problem 1:

There’s the error when I try to boot the VM on the new XCP 1.6 host.   Has anyone seen this?


[root@xen65 ~]# xe vm-start vm=srch-plgr00

The server failed to handle your request, due to an internal error.  The given message may give details useful for debugging the problem.

message: xenopsd internal error: VM = b5de268f-9c4c-239f-1980-de12010ecfa4; domid = 15; Bootloader.Bad_error Using <class 'grub.GrubConf.GrubConfigFile'> to parse /grub/menu.lst

Traceback (most recent call last):

  File "/usr/bin/pygrub", line 962, in ?


  File "/usr/bin/pygrub", line 782, in copy_from_image

    data = "" dataoff)

IOError: [Errno 22] Invalid argument



Here’s problem 2:

I tried to boot the VM in the original XCP 1.1 host, and it still won’t start.  I have seen many posts state boot issues after a kernel update relating to pygrub.  However, I didn’t do any kernel update, and this looks like an invalid argument in “ramdisk.”     


[root@xen04 ~]# xe vm-start vm=srch-plgr00

Error code: Traceback (most recent call last):

Error parameters:   File "/usr/bin/pygrub", line 768, in ?,     data = "" IOError: [Errno 22] Invalid argument,


I compared grub.conf to a known good bootable VM on the same host, and it looks the same.  I don’t see anything wrong ramdisk(initrd) parameter.


[root@xen04 ~]# xe-edit-bootloader -n srch-plgr00 -p 1

# grub.conf generated by anaconda


# Note that you do not have to rerun grub after making changes to this file

# NOTICE:  You have a /boot partition.  This means that

#          all kernel and initrd paths are relative to /boot/, eg.

#          root (hd0,0)

#          kernel /vmlinuz-version ro root=/dev/xvda3

#          initrd /initrd-[generic-]version.img






title Red Hat Enterprise Linux (2.6.32-220.4.2.el6.x86_64)

        root (hd0,0)

        kernel /vmlinuz-2.6.32-220.4.2.el6.x86_64 ro root=UUID=9caebb06-8102-4158-853f-7f07e66daefa rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFO$

        initrd /initramfs-2.6.32-220.4.2.el6.x86_64.img


I tried without success to change the PV-bootable-args to see if that works.

xe vm-param-set uuid=738e0e50-c579-b35f-a8e1-d03d23274a50 PV-bootloader-args="--kernel=/vmlinuz-2.6.32-220.4.2.el6.x86_64 --ramdisk=/initramfs-2.6.32-220.4.2.el6.x86_64.img"


Here’s the params for my VM on the original XCP 1.1 host.

[root@xen04 ~]# xe vm-list params=all  name-label=srch-plgr00

uuid ( RO)                          : 738e0e50-c579-b35f-a8e1-d03d23274a50

                    name-label ( RW): srch-plgr00

              name-description ( RW): Installed via xe CLI

                  user-version ( RW): 1

                 is-a-template ( RW): false

                 is-a-snapshot ( RO): false

                   snapshot-of ( RO): <not in database>

                     snapshots ( RO):

                 snapshot-time ( RO): 19700101T00:00:00Z

                 snapshot-info ( RO):

                        parent ( RO): c94549a7-a39e-cca7-b347-458f9e3cfc8c

                      children ( RO):

             is-control-domain ( RO): false

                   power-state ( RO): halted

                 memory-actual ( RO): 25769803776

                 memory-target ( RO): <expensive field>

               memory-overhead ( RO): 38797312

             memory-static-max ( RW): 536870912

            memory-dynamic-max ( RW): 536870912

            memory-dynamic-min ( RW): 536870912

             memory-static-min ( RW): 512000

              suspend-VDI-uuid ( RO): <not in database>

                  VCPUs-params (MRW):

                     VCPUs-max ( RW): 32

              VCPUs-at-startup ( RW): 8

        actions-after-shutdown ( RW): Destroy

          actions-after-reboot ( RW): Restart

           actions-after-crash ( RW): Restart

                 console-uuids (SRO):

                      platform (MRW): nx: false; acpi: true; apic: true; pae: true; viridian: true

            allowed-operations (SRO): changing_dynamic_range; changing_static_range; make_into_template; destroy; export; start_on; start; clone; copy; snapshot

            current-operations (SRO):

            blocked-operations (MRW):

           allowed-VBD-devices (SRO): <expensive field>

           allowed-VIF-devices (SRO): <expensive field>

                possible-hosts ( RO): <expensive field>

               HVM-boot-policy ( RW):

               HVM-boot-params (MRW):

         HVM-shadow-multiplier ( RW): 1.000

                     PV-kernel ( RW):

                    PV-ramdisk ( RW):

                       PV-args ( RW): ks=http://cobbler.sv.walmartlabs.com/cblr/svc/op/ks/system/srch-plgr00 ksdevice=eth0 noipv6 utf8

               PV-legacy-args ( RW):

                 PV-bootloader ( RW): pygrub

            PV-bootloader-args ( RW):

           last-boot-CPU-flags ( RO):

              last-boot-record ( RO): <expensive field>

                   resident-on ( RO): <not in database>

                      affinity ( RW): <not in database>

                  other-config (MRW): last_shutdown_time: 20130307T17:41:35Z; last_shutdown_action: Destroy; last_shutdown_initiator: external; last_shutdown_reason: halted; install-repository: http://cobbler.sv.walmartlabs.com/cblr/links/rhel6-x86_64/; mac_seed: 44d1fb0d-e05a-6349-784c-3672bc70f7d9; linux_template: true; install-methods: cdrom,nfs,http,ftp; rhel6: true

                        dom-id ( RO): -1

               recommendations ( RO): <restrictions><restriction field="memory-static-max" max="17179869184" /><restriction field="vcpus-max" max="8" /><restriction property="number-of-vbds" max="7" /><restriction property="number-of-vifs" max="7" /></restrictions>

                 xenstore-data (MRW):

                 ha-always-run ( RW): false

           ha-restart-priority ( RW):

                         blobs ( RO):

                    start-time ( RO): 20121231T18:56:47Z

                  install-time ( RO): 20120321T02:45:09Z

                  VCPUs-number ( RO): 8

             VCPUs-utilisation (MRO): <expensive field>

                    os-version (MRO): name: Red Hat Enterprise Linux Server release 6.2 (Santiago); uname: 2.6.32-220.4.2.el6.x86_64; distro: rhel; major: 6; minor: 2

            PV-drivers-version (MRO): major: 5; minor: 6; micro: 100; build: 47383

         PV-drivers-up-to-date ( RO): true

                        memory (MRO):

                         disks (MRO):

                      networks (MRO): 0/ip:

                         other (MRO): platform-feature-multiprocessor-suspend: 1; feature-balloon: 1

                          live ( RO): true

    guest-metrics-last-updated ( RO): 20130303T12:23:06Z

                   cooperative ( RO): <expensive field>

             protection-policy ( RW): <not in database>

         is-snapshot-from-vmpp ( RO): false

                          tags (SRW):




Xen-api mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.