[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-API] Attach iSCSi to XCP 1.6

Hi Samir,

 From XCP interface:
1- Disk & Storage Repositories-> Attach Existing Storage Repository

if you are using this lun for the first time, you have to select "Create new storage repository", otherwise XCP expect to find some XCP metadata on the iscsi LUN.

Another problem you may bump into is that the lvm filter are not set proprely on the home made SAN and since XCP create logical volumes on the iscsi LUN, it can confuse the iscsi target server when it boots and finds lv in lv (look for /etc/lvm/lvm.conf on SAN).



2- Type the root password
3- Select Software iSCSI
4- In New Storage Repository Window, type:
** Name: VMs
** Desc: VMs
** Initiator IQN: iqn.2013-03.com.example:f503e924
** Port number: 3260
** Hostnameof iSCSI target:
** username: nasusr
** Password : nasusr password as defined in Openfiler
5- Hit OK
6- XCP show the iSCSI's I have in Openfiler.
7- I choose TPTG 0 iqn.2006-01.com.example:nas.vms
8- Probing for LUNs, I get an error message "(' timed out',)"

But when I go to local command shell and I type these commands, it works:
1- *iscsiadm -m discovery -t st -p*: displays all the
iSCSI I have in my openfiler
2- *iscsiadm -m node -p --login*:  successful on all iSCSI
3- *fdisk -l*: I see all the iSCSI drives with the mention "Donesn't
contain a valide partition table"

I tried to apply the fix listed in
but I could n't find:
- In /etc/rc.sysinit:
           if [ -x /sbin/lvm.static ]; then
                           if /sbin/lvm.static vgscan --mknodes
--ignorelockingfailure > /dev/null 2>&1 ; then
                                           action $"Setting up Logical
Volume Management:" /sbin/lvm.static vgchange -a y --ignorelockingfailure
- In /etc/rc.sysinit: keyword filter not found

I tried also adding iSCSI using XenCenter 6.1 build 644, but I'm getting
the error message: Discovering LUNs failed

My questions:
1- Why I can't attach the iSCSI from the XCP interface : It works from
the command line
2- Why *fdisk -l*says the iSCSI devices are not partitionned but
iqn.2006-01.com.example:nas.vms is already ext3 formated in openfiler

This body part will be downloaded on demand.

Denis Cardon
Tranquil IT Systems
Les Espaces Jules Verne, bâtiment A
12 avenue Jules Verne
44230 Saint Sébastien sur Loire
tel : +33 (0)

Xen-api mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.