[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-API] Unable to move VMs between XCP hosts? odd.

  • To: xen-api@xxxxxxxxxxxxx
  • From: "Michael @ Professional Edge LLC" <m3@xxxxxxxxxxxxxxxxxxxxxxx>
  • Date: Tue, 04 Jun 2013 01:06:57 -0700
  • Delivery-date: Tue, 04 Jun 2013 08:11:44 +0000
  • List-id: User and development list for XCP and XAPI <xen-api.lists.xen.org>


I could use some thoughts on this one.  As I'm straight out confused.

XCP 1.1 - Host #1 - multiple - DomU RHEL 5.8 x64 - all work fine.

XCP 1.1 - Host #2 deployed about 3 months ago - I exported several VM's from Host#1 - to XVA files using Xencenter 6.0 - imported into Host #2 - everything worked fine.

XCP 1.6 - new Host #3 deployed last week - every VM I export from Host#1 or Host#2 - imports fine... but I'm unable to login, after a successful import.

[root@host3 ~]# xe console vm=test1
Kernel 2.6.18-308.1.1.el5xen on an x86_64

(test1.FQDN) login: root

Permission denied
( and btw - if I type the wrong password - the error says - "Login incorrect" - when I type the correct password it says - "Permission denied". )

So then I tried an export of a DomU RHEL 5.8 x64 VM - from Host#1 - and imported it into Host#2 - and same issue... "Permission denied". So it's not an XCP to 1.1 to XCP 1.6 issue.

I went back to my original Host#1 XCP 1.1 host - and the very first RHEL 5.8 machine I built - I kept as a vanilla host ( vmtemplate ).

When I export the "vmtemplate" from Host#1 - into Host#3 - it works fine. ( and into Host#2 it works fine ).

The only thing I can figure is... my original RHEL 5.8 ( vmtemplate ) never had any Xen Guest Tools installed. I used the original XCP 1.1 - xs-tools.iso - then did the Fix#1 ( http://wiki.xen.org/wiki/Using_XenCenter_to_manage_XCP ) - I never did this procedure on my original "RHEL 5.8 (vmtemplate)". Could this be related as to why only my original vmteplate machine can be moved between XCP hosts?

I tried removing - xe-guest-utilities-1.1.0-651 and xe-guest-utilities-xenstore-1.1.0-651 ; no effect - same issue.

I also tried the - xs-tools-iso - from the XCP 1.6 - and upgrading a DomU from Host#1 to the guest tools 1.6 - did another export... same issue after successful import on Host#3 ( or Host#2 ) - I still can't login... "Permission denied" when typing the correct password - and "Login incorrect" when I type the wrong password.

Anyone have any thoughts?


Xen-api mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.