[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-API] trouble with VDI relocation

  • To: <xen-api@xxxxxxxxxxxxx>
  • From: Germano Percossi <germano.percossi@xxxxxxxxxx>
  • Date: Thu, 4 Aug 2016 10:50:10 +0100
  • Delivery-date: Thu, 04 Aug 2016 09:50:22 +0000
  • List-id: User and development list for XCP and XAPI <xen-api.lists.xen.org>


Would you mind sending a bunch of logs, starting with /var/log/SMlog?

If you want to post a bugreport, instead, provide a link for
downloading it.


On 08/03/2016 02:39 PM, Farkhad Badalov wrote:
Dear community members,

We use XCP 1.6 on 2 servers wich joined in pool and iSCSI shared
storage . Couple of days before we lost 2nd server in the result of
power loss in datacenter. After it I try to relocate the VM harddisks
but every time get this error "The VDI is not available"
In cli it gives little bit more info
Error parameters: , The VDI is not available [opterr=VDI
510523ef-5328-4130-ba0f-e3aa7264cae2 already attached RW]

I've tried this manual http://support.citrix.com/article/CTX132387 with
vm powerstate reset and resetvdis script but unfortunately even if I
moved VM in list of available for start it's still continue to give such
kind error.

After it I remove troubled host from pool via this
manual http://discussions.citrix.com/topic/271368-remove-xenserver-from-pool/
and use powerstate reset again with same result as above.

Since all VHD files placed on storage I'm absolutely sure that this hdd
images are untoched, but I can't re-attach them on new host.

So could you recommend something for successful solving of this issue?


Xen-api mailing list

Xen-api mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.