[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [Xen-changelog] [xen master] libxl: Use proper path for 'do_flr' functionality.
commit ab78724fc5628318b172b4344f7280621a151e1b Author: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx> AuthorDate: Tue Jul 8 15:00:37 2014 -0400 Commit: Ian Campbell <ian.campbell@xxxxxxxxxx> CommitDate: Thu Jul 10 15:54:16 2014 +0100 libxl: Use proper path for 'do_flr' functionality. Commit f74035d3b1e827ff6ff1873e2f10feb011a8d0d2 "xl: PCI code cleanups" introduced an regression where it changed the name from: /sys/bus/pci/drivers/pciback/do_flr to libxl_sprintf(ctx, "%s/pciback/do_flr", SYSFS_PCI_DEV); And SYSFS_PCI_DEV is "/sys/bus/pci/devices", meaning we would do /sys/bus/pci/devices/pciback/do_flr. The proper define should have been SYSFS_PCIBACK_DRIVER, which is what this patch does. Signed-off-by: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx> Acked-by: Ian Campbell <ian.campbell@xxxxxxxxxx> --- tools/libxl/libxl_pci.c | 2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/tools/libxl/libxl_pci.c b/tools/libxl/libxl_pci.c index 44d0453..2782d0e 100644 --- a/tools/libxl/libxl_pci.c +++ b/tools/libxl/libxl_pci.c @@ -965,7 +965,7 @@ static int libxl__device_pci_reset(libxl__gc *gc, unsigned int domain, unsigned char *reset; int fd, rc; - reset = libxl__sprintf(gc, "%s/pciback/do_flr", SYSFS_PCI_DEV); + reset = libxl__sprintf(gc, "%s/do_flr", SYSFS_PCIBACK_DRIVER); fd = open(reset, O_WRONLY); if (fd >= 0) { char *buf = libxl__sprintf(gc, PCI_BDF, domain, bus, dev, func); -- generated by git-patchbot for /home/xen/git/xen.git#master _______________________________________________ Xen-changelog mailing list Xen-changelog@xxxxxxxxxxxxx http://lists.xensource.com/xen-changelog
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |