[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [Xen-changelog] [xen master] arm: use existing __section() macro instead of opencoding it
commit 522b9d0be31048e51079b2b7a8f511084a016221 Author: Andrew Cooper <andrew.cooper3@xxxxxxxxxx> AuthorDate: Mon Jun 8 15:38:39 2015 +0200 Commit: Jan Beulich <jbeulich@xxxxxxxx> CommitDate: Mon Jun 8 15:38:39 2015 +0200 arm: use existing __section() macro instead of opencoding it No functional change Signed-off-by: Andrew Cooper <andrew.cooper3@xxxxxxxxxx> Acked-by: Ian Campbell <ian.campbell@xxxxxxxxxx> --- xen/include/asm-arm/device.h | 2 +- xen/include/asm-arm/platform.h | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) diff --git a/xen/include/asm-arm/device.h b/xen/include/asm-arm/device.h index a72f7c9..5d0a4cd 100644 --- a/xen/include/asm-arm/device.h +++ b/xen/include/asm-arm/device.h @@ -71,7 +71,7 @@ enum device_class device_get_class(const struct dt_device_node *dev); #define DT_DEVICE_START(_name, _namestr, _class) \ static const struct device_desc __dev_desc_##_name __used \ -__attribute__((__section__(".dev.info"))) = { \ +__section(".dev.info") = { \ .name = _namestr, \ .class = _class, \ diff --git a/xen/include/asm-arm/platform.h b/xen/include/asm-arm/platform.h index 746e126..283b50f 100644 --- a/xen/include/asm-arm/platform.h +++ b/xen/include/asm-arm/platform.h @@ -67,7 +67,7 @@ void platform_dom0_gnttab(paddr_t *start, paddr_t *size); #define PLATFORM_START(_name, _namestr) \ static const struct platform_desc __plat_desc_##_name __used \ -__attribute__((__section__(".arch.info"))) = { \ +__section(".arch.info") = { \ .name = _namestr, #define PLATFORM_END \ -- generated by git-patchbot for /home/xen/git/xen.git#master _______________________________________________ Xen-changelog mailing list Xen-changelog@xxxxxxxxxxxxx http://lists.xensource.com/xen-changelog
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |