[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [xen staging] x86/entry: move .init.text section higher up in the code for readability
commit fe3f50726e878c81985e28282927d151a0d49de5 Author: Jane Malalane <jane.malalane@xxxxxxxxxx> AuthorDate: Thu Aug 18 09:30:10 2022 +0200 Commit: Jan Beulich <jbeulich@xxxxxxxx> CommitDate: Thu Aug 18 09:30:10 2022 +0200 x86/entry: move .init.text section higher up in the code for readability .init.text is a small section currently located amongst .text.entry code. Move it above .text.entry. This has no functional change but makes the code a bit more readable. Suggested-by: Andrew Cooper <andrew.cooper3@xxxxxxxxxx> Signed-off-by: Jane Malalane <jane.malalane@xxxxxxxxxx> Reviewed-by: Jan Beulich <jbeulich@xxxxxxxx> --- xen/arch/x86/x86_64/entry.S | 19 +++++++++---------- 1 file changed, 9 insertions(+), 10 deletions(-) diff --git a/xen/arch/x86/x86_64/entry.S b/xen/arch/x86/x86_64/entry.S index 26bf2f1941..9b34150bc7 100644 --- a/xen/arch/x86/x86_64/entry.S +++ b/xen/arch/x86/x86_64/entry.S @@ -140,6 +140,15 @@ process_trap: call create_bounce_frame jmp test_all_events + .section .init.text, "ax", @progbits +ENTRY(early_page_fault) + ENDBR64 + movl $TRAP_page_fault, 4(%rsp) + SAVE_ALL + movq %rsp, %rdi + call do_early_page_fault + jmp restore_all_xen + .section .text.entry, "ax", @progbits /* %rbx: struct vcpu, interrupts disabled */ @@ -982,16 +991,6 @@ ENTRY(double_fault) call do_double_fault BUG /* do_double_fault() shouldn't return. */ - .pushsection .init.text, "ax", @progbits -ENTRY(early_page_fault) - ENDBR64 - movl $TRAP_page_fault,4(%rsp) - SAVE_ALL - movq %rsp,%rdi - call do_early_page_fault - jmp restore_all_xen - .popsection - ENTRY(nmi) ENDBR64 pushq $0 -- generated by git-patchbot for /home/xen/git/xen.git#staging
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |