[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Fedora Core 3 + Xen-unstable

Hi all,

Here is what I have right now.  I've played with xen a little bit.  Last week I was able to do the following:

1) Install Fedora Core 4 Test 1 on an Intel PIII system with a gig a ram in it.
2) Run yum update on the devel repositories
3) I found that I was having a little difficulty finding kernel-xen0 and kernel-xenU to get pulled from the mirror list of yum repositories off of fedora's site.
4) I finally found that Fedora's download server had it in the development section.  I pointed my yum repositories to fedora's site and was able to install the kernel-xen0 and kernel-xenU packages.  
5) I rebooted and had xen available.  I ran /etc/init.d/xend start and was able to use xm create to create some domains

Things seemed to work great until rebooted one of the domains via a  login through an ssh connection.

python pegged the CPU and for about 5 minutes my cpu was pegged.  I killed that process and thus killed xend.

So my next step was to wipe my Fedora Core 4 Test 1 machine and install Fedora Core 3 instead (since the HOWTO's were using that version to base their HOWTO's on).

So, I regened the server as Fedora Core 3, ran yum update and noticed that this time, yum updated me to gcc 4.0 amongst other things.
1) I went on the hunt for kernel-xen0 and kernel-xenU again and could not find anything available anywhere...  mind you, this is approximately a week after I found it before.
2) I decided to do the build myself from scratch.  I downloaded the latest xen-unstable source and tried to run "make dist" on it.  This is what I recieved:

[root@xen01 src]# tar zxf xen-unstable-src.tgz
[root@xen01 src]# head xen-unstable/C
ChangeLog  Config.mk  COPYING    
[root@xen01 src]# head xen-unstable/ChangeLog
ChangeSet@xxxxxx, 2005-03-28 22:51:31+01:00, kaf24@xxxxxxxxxxxxxxxxxxxx

ChangeSet@xxxxxxxxxxxxx, 2005-03-28 22:45:46+01:00, kaf24@xxxxxxxxxxxxxxxxxxxx
  Add a tags target to the Xen Makefile.
  Signed-off-by: Rik van Riel <riel@xxxxxxxxxx>
  Signed-off-by: Keir Fraser <keir@xxxxxxxxxxxxx>

ChangeSet@xxxxxx, 2005-03-28 22:16:12+01:00, kaf24@xxxxxxxxxxxxxxxxxxxx
  Merge firebug.cl.cam.ac.uk:/local/scratch/kaf24/xen-2.0-testing.bk

[root@xen01 src]# cd xen-unstable
[root@xen01 xen-unstable]# make dist
....60-70 lines of compilation....
gcc -g -nostdinc -fno-builtin -fno-common -fno-strict-aliasing -iwithprefix include -Wall -Werror -Wno-format -pipe -I/usr/src/xen-unstable/xen/include -Wno-pointer-arith -Wredundant-decls -O3 -fomit-frame-pointer -msoft-float -m32 -march=i686 -DNDEBUG -c multicall.c -o multicall.o
gcc -g -nostdinc -fno-builtin -fno-common -fno-strict-aliasing -iwithprefix include -Wall -Werror -Wno-format -pipe -I/usr/src/xen-unstable/xen/include -Wno-pointer-arith -Wredundant-decls -O3 -fomit-frame-pointer -msoft-float -m32 -march=i686 -DNDEBUG -c page_alloc.c -o page_alloc.o
page_alloc.c:618: error: static declaration of ‘page_scrub_lock’ follows non-static declaration
/usr/src/xen-unstable/xen/include/xen/mm.h:42: error: previous declaration of ‘page_scrub_lock’ was here
make[2]: *** [page_alloc.o] Error 1
make[2]: Leaving directory `/usr/src/xen-unstable/xen/common'
make[1]: *** [/usr/src/xen-unstable/xen/xen] Error 2
make[1]: Leaving directory `/usr/src/xen-unstable/xen'
make: *** [xen] Error 2
[root@xen01 xen-unstable]#

Does anyone have any suggestions on getting past this?  I also tried the stable release and testing release and have similar errors.

Information Technology Exchange Center
Systems Programmer/Analyst
E-mail: Joe.Hoot@xxxxxxxxxxxxx
Office: (716)878-4644
Cell: (716)908-6292
Fax: (716)878-3485
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.