[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] xen, selinux

Mail reformatted (prequote posting kills readability)

On Sun, Apr 10, 2005 at 06:02:05PM +0100, Mark Williamson wrote:
> On Monday 11 April 2005 17:36, Joe.Hoot@xxxxxxxxxxxxx wrote:
> > On 04/11/2005 11:57 AM, Shahzad Chohan wrote:
> > > Could someone please help me.
> > >
> > > Basically when I run rhel 4 or fc3, or fc4 under xen, the system never
> > > boots. It always hangs after starting SE linux. Can anyone please help
> > > me with this.

Just to track the cause: does it boot with kernel cmdline "selinux=0"?
(warning: this disables selinux, so new files get no selinux-label! You
may have to relabel them on next boot with selinux enabled)

> > I get the same thing.. and yes, I've move /lib/tls to /lib/tls.disabled in
> > both my dom0 and domU filesystems.

That speeds things up, but it should boot anyway.

> Are either of you using an initrd?  You'll need it to make udev work.

If that's the problem it can easily be solved without using an initrd:
Mount and chroot into the FC guest filesystem before you boot it and run

   /sbin/MAKEDEV null console zero

See here


> I think there's one for FC3 on the Xen FAQ page.



Regards, /nils.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.