[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Kernel panic - not syncing

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: "Woller, Thomas" <thomas.woller@xxxxxxx>
  • Date: Tue, 12 Apr 2005 17:25:37 -0500
  • Delivery-date: Tue, 12 Apr 2005 22:25:44 +0000
  • List-id: Xen user discussion <xen-users.lists.xensource.com>
  • Thread-index: AcU/ro0+0+lfySm4QVOc9uGU2F7egQ==
  • Thread-topic: Kernel panic - not syncing

Yes, another kernel panic - not syncing question.  Thanks for any
assistance, I'm at a loss at this point.

Xen-unstable from 2005/04/07 - building sources fine under Suse 9.3 RC4
x86_32 installation. 
Xen 2.0 building fine under same enviroment. The Xen package released
within Suse 9.3 RC4 working fine, as in Dom0 and Dom1 both come up, and
I was running 8 xenU guest OSes each with it's own distinct ttylinux
rootfs (as loopback devices).

The problem at this point, is with starting up any Dom1 using the
xen-unstable built kernel from 2005/04/07.  
I am building static kernels (no modules) for the vmlinuz-2.6.11-xen0
(Dom0) and vmlinuz-2.6.11-xenU (Dom1+) kernels, using the default
defconfig files, except removing module support. The Dom0 starts up fine
with "xend start", but when starting up any Dom1 kernels, I obtain the
"Kernel panic - not syncing: No init found..." message.  "xm list" and
other control commands work fine, so Dom0 seems to be stable.  Btw,
using the xen0 (dom0) kernel as the unprivileged kernel, behaves the
same as the xenU kernel.

I have created a loopback device as the root fs, ext3 fs, with ttylinux
distro.  This same loopback device worked fine with same config files,
as rootfs under the 9.3 RC4 shipped packages.

Seems like the loopback rootfs is mounted properly, as seen from the log
info (see below). Also, when I try to mount manually after starting up
the Dom1 (and hanging), then the mount fails with a busy error.  Doing a
"xm shutdown ttylinux-tmp" destroys Dom1 and then I can manually mount
the loopback fs. So, I know that I am mounting the loopback rootfs
during the Dom1 kernel boot process.  Additionally, mounting and
fsck'ing this same loopback rootfs works fine, so the integrity of the
rootfs seems to be ok.

Wondering if initrd work needs to be done, or if some sort of udev
issue? Since I had this working with the 9.3 shipped xen packages,
should be something simple that I am overlooking.  This I my first xen
experience btw, looks pretty good so far.  I did have some problems with
mixed xen tools, but "make installs" fixed those issues.  I tried
mounting read-only vs rw, no change, tried using another rootfs/ttylinux
distro, no help.

Here is the xm command line, xen config file and log information:
xm create xen-ttylinux-cfg-tmp -c 

>>>>>>>>>>>> xen-ttylinux-cfg-tmp FILE START 
kernel = "/boot/vmlinuz-2.6.11-xenU"
memory = 256
name = "ttylinux-tmp"
nics = 1
dhcp = "off"
disk = ['file:/usr/local/src/xenfs/ttylinux-xentmp,hda1,w']
root = "/dev/hda1 ro"
cpu = -1
>>>>>>>>>>> FILE END 

>>>>>>>>>> console Dom1 output start <<<<<<<<<<<<<
Linux version 2.6.11-xen0 (root@linux-udp02457290uds) (gcc version 3.3.5
20050117 (prerelease) (SUSE Linux)) #3 Tue Apr 12 15:08:58 CDT 2005
BIOS-provided physical RAM map:
 Xen: 0000000000000000 - 0000000010000000 (usable)
256MB LOWMEM available.
DMI not present.
IRQ lockup detection disabled
Allocating PCI resources starting at 10000000 (gap: 10000000:f0000000)
Built 1 zonelists
Kernel command line:  root=/dev/hda1 ro
Initializing CPU#0
PID hash table entries: 2048 (order: 11, 32768 bytes)
Xen reported: 2197.158 MHz processor.
Using tsc for high-res timesource
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Memory: 253824k/262144k available (3336k kernel code, 7996k reserved,
1010k data, 332k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode...
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 1024K (64 bytes/line)
CPU: AMD Opteron(tm) Processor - model unknown stepping 00
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... disabled
NET: Registered protocol family 16
PCI: Using configuration type Xen
xen_mem: Initialising balloon driver.
SCSI subsystem initialized
PCI: Probing PCI hardware
PCI: Probing PCI hardware
PCI: Probing PCI hardware (bus 00)
Grant table initialized
IA-32 Microcode Update Driver: v1.14-xen <tigran@xxxxxxxxxxx>
Installing knfsd (copyright (C) 1996 okir@xxxxxxxxxxxx).
Initializing Cryptographic API
Linux agpgart interface v0.100 (c) Dave Jones
[drm] Initialized drm 1.0.0 20040925
i8042.c: Can't read CTR while initializing i8042.
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered
Floppy drive(s): fd0 is unknown type 15 (usb?), fd1 is unknown type 15
Failed to obtain physical IRQ 6
floppy0: no floppy controllers found
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
loop: loaded (max 8 devices)
HP CISS Driver (v 2.6.4)
Intel(R) PRO/1000 Network Driver - version
Copyright (c) 1999-2004 Intel Corporation.
pcnet32.c:v1.30i 06.28.2004 tsbogend@xxxxxxxxxxxxxxxx
e100: Intel(R) PRO/100 Network Driver, 3.3.6-k2-NAPI
e100: Copyright(c) 1999-2004 Intel Corporation
Xen virtual console successfully installed as tty1
Event-channel device installed.
Blkif frontend is using grant tables.
xen_blk: Initialising virtual block device driver
xen_net: Initialising virtual ethernet driver.
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 50MHz system bus speed for PIO modes; override with
Red Hat/Adaptec aacraid driver (1.1.2-lk2 Apr 12 2005)
3ware Storage Controller device driver for Linux v1.26.02.000.
mice: PS/2 mouse device common for all mice
md: raid0 personality registered as nr 2
md: raid1 personality registered as nr 3
md: raid5 personality registered as nr 4
raid5: automatically using best checksumming function: pIII_sse
   pIII_sse  :  4772.800 MB/sec
raid5: using function: pIII_sse (4772.800 MB/sec)
md: md driver 0.90.1 MAX_MD_DEVS=256, MD_SB_DISKS=27
device-mapper: 4.4.0-ioctl (2005-01-12) initialised: dm-devel@xxxxxxxxxx
NET: Registered protocol family 2
IP: routing cache hash table of 2048 buckets, 16Kbytes
TCP established hash table entries: 16384 (order: 5, 131072 bytes)
TCP bind hash table entries: 16384 (order: 4, 65536 bytes)
TCP: Hash tables configured (established 16384 bind 16384)
ip_conntrack version 2.1 (2048 buckets, 16384 max) - 244 bytes per
ip_tables: (C) 2000-2002 Netfilter core team
NET: Registered protocol family 1
NET: Registered protocol family 17
Bridge firewalling registered
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
EXT3-fs: mounted filesystem with ordered data mode.
VFS: Mounted root (ext3 filesystem) readonly.
Freeing unused kernel memory: 332k freed
kjournald starting.  Commit interval 5 seconds
Kernel panic - not syncing: No init found.  Try passing init= option to
>>>>>>>>>> console Dom1 output end <<<<<<<<<<<<<

>>>>>>>>> here is the menu.lst from the root partition <<<<<<<
# Modified by YaST2. Last modification on Fri Apr  8 21:15:18 UTC 2005

color white/blue black/light-gray
default 0
timeout 8
gfxmenu (hd0,2)/boot/message

###Don't change this comment - YaST2 identifier: Original name: linux###
title SUSE LINUX 9.3
    kernel (hd0,2)/boot/vmlinuz root=/dev/hda3 vga=0x31a selinux=0
splash=silent resume=/dev/hda2  showopts
    initrd (hd0,2)/boot/initrd

###Don't change this comment - YaST2 identifier: Original name: xen###
title XEN
    kernel (hd0,2)/boot/xen dom0_mem=983040
#    kernel (hd0,2)/boot/xen.gz.suse_93_RC4 dom0_mem=983040
    module (hd0,2)/boot/vmlinuz-xen root=/dev/hda3 vga=0x31a selinux=0
splash=silent resume=/dev/hda2  showopts
    module (hd0,2)/boot/initrd-xen

title XEN-2.0
    kernel (hd0,2)/boot/xen.gz dom0_mem=983040
    module (hd0,2)/boot/vmlinuz-2.6.10-xen0 root=/dev/hda3 vga=0x31a
selinux=0  splash=silent resume=/dev/hda2  showopts
    module (hd0,2)/boot/initrd-xen

title XEN-2.6.11-unstable
    kernel (hd0,2)/boot/xen.gz-2.6.11 dom0_mem=983040
    module (hd0,2)/boot/vmlinuz-2.6.11-xen0 root=/dev/hda3 vga=0x31a
selinux=0  splash=silent resume=/dev/hda2  showopts
    module (hd0,2)/boot/initrd-xen

###Don't change this comment - YaST2 identifier: Original name: SUSE
LINUX 9.3 (/dev/hda1)###
title SUSE LINUX 9.3 (/dev/hda1)
    kernel (hd0,0)/vmlinuz root=/dev/hda6 vga=0x31a selinux=0
splash=silent console=tty0 resume=/dev/hda2  showopts
    initrd (hd0,0)/initrd

###Don't change this comment - YaST2 identifier: Original name:
title Failsafe -- SUSE LINUX 9.3
    kernel (hd0,2)/boot/vmlinuz root=/dev/hda3 showopts ide=nodma
apm=off acpi=off vga=normal noresume selinux=0 barrier=off nosmp noapic
maxcpus=0  3
    initrd (hd0,2)/boot/initrd

###Don't change this comment - YaST2 identifier: Original name:
title Memory Test
    kernel (hd0,2)/boot/memtest.bin
>>>>>>>>>>end menu.lst 

>>>>>>>> here is the /etc/fstab from the ttylinux fs <<<<<<<<
#/dev/ram0              /               ext2    defaults
0 0
/dev/hda1               /               ext3    defaults
0 0
none                    /proc           proc    defaults
0 0
none                    /dev/pts        devpts  gid=2,mode=620
0 0
>>>>>>>>>> end /etc/fstab <<<<<<<<<<<<<

Thanks for any help
Tom Woller
Systems Engineer
AMD Corporation

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.