[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Using NetBSD as DomainU with a Linux Host

  • To: Xen-users@xxxxxxxxxxxxxxxxxxx
  • From: Kenneth Power <telcor@xxxxxxxxx>
  • Date: Thu, 21 Apr 2005 08:47:26 -0500
  • Delivery-date: Thu, 21 Apr 2005 13:47:14 +0000
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta; d=gmail.com; h=received:message-id:date:from:reply-to:to:subject:mime-version:content-type:content-transfer-encoding:content-disposition; b=okC73YoXbxkZknLd4/xpDgyGIbyg3hNJbFcs9U6BCc3bN3p1Lwfw5zMEsx8wy+z55RMG/AOv62LZpnFMxPjsgOBADZdxWTlAv/0HD7O8rpXp9ozCEnNwOdrClYGuZHP/jV3DRxAF6UTO/4fd7f80dwF9iAAlbq6/6xwzbHmspFs=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

I have a Debian Domain0 host with several harddrive partitions
(hde5-11) to export to domainU OSs. I know how to do this for a Linux
domainU, and have several working. However I'm having no success
exporting a partition for NetBSD to use. I've tried various
manifestations of:

disk = ['phy:hde5,wd0e,w']
disk = ['phy:hde6,wd0d,w']

And many other letters, all to no availa. Obviously I know little
about NetBSD ;) But I'm trying this for learning purposes. I've tried
following http://www.netbsd.org/Ports/xen/howto.html for clues but am
still getting nowhere.

Oh, let me be a little more specific. I found a NetBSD bootstrap
kernel for a Xend domainU, that way I can install NetBSD without
physically booting the machine into the install. The bootstrap kernel
works wonderfully, except it cannot find any drive partitions to use,
leading me to believe I'm exporting them incorrectly.

Since the NetBSD/Xen Howto states that Linux stat()'s the drive device
I've tried mknod'ing various wd0? devices, still to no avail.

What am I doing wrong? Any clues?

Kenneth Power

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.