[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] xen on suse 9.3 and software raid

Gerd Knorr wrote:
Had a look today, figured mkinitrd has a bug which causes it using the
default kernel modules, not the xen kernel ones in case you have both
-default and -xen installed (which most likely is the case).

Try the patch below, rerun mkinitrd, reboot and see whenever it works
better then.

I can confirm what Chris Epicier reported.

Your patch does indeed fix the mkinitrd bug. I looked at the contents
of the generated initrd and it now contains only the disired modules.
Thank you.

However the software raid1 (mirror) is still not working with
kernel- from the SuSE-9.3 distribution. I guess
the mkinitrd bug isn't the source of the problem.

I tried various kernels from Kurt Garloff's web page

Here is what I found

kernel version                   software raid1 status
kernel-          broken
kernel-xen-2.6.8-24.14.i586.rpm  working
kernel-xen-2.6.10-20.i586.rpm    broken
kernel-xen-  broken

So I have a workaround, use kernel-xen-2.6.8-24.14.i586.rpm .

Thanks for your help.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.