[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] only one NIC supported?

On Friday 03 February 2006 11:39 am, Fernando Maior wrote:


> Hi,
> This may be a wrapper script example for 4 nics on dom0, each one bridged:
> ----------------->8
> #!/bin/bash
> /etc/xen/scripts/network-bridge start bridge=xenbr0 netdev=eth0 vifnum=0
> /etc/xen/scripts/network-bridge start bridge=xenbr1 netdev=eth1 vifnum=1
> /etc/xen/scripts/network-bridge start bridge=xenbr2 netdev=eth2 vifnum=2
> /etc/xen/scripts/network-bridge start bridge=xenbr3 netdev=eth3 vifnum=3
> ----------------->8

Thanks. That kind of worked. I created a startup script in /etc/init.d
and set it to come up just before xend with the above for two bridges.
Now on shutdown it hangs (there is nothing in the script to bring
the bridges down, it only has start.) At shutdown it says something
about xenbr0 entering disabled state. This seems like a lot of hoops
to jump through just to get another interface to bridge, especially
given that 3.0.0 did it without a problem---it just worked.

There has to be a better way, no?

Best Regards,
David Koski

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.