[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Root fs on LVM on software RAID1?

On 23 Feb 2006, at 11:50, Petersson, Mats wrote:
[snip big chunk of mkinitrd problems which I'm not trying to help
resolve - I can just barely make it work when I do it myself... ;-)]


For Xen, you should not use initrd command in grub to load initrd - you
want to use module to load the initrd too. So the line would be
"module /initrd.img-xen-"

This will avoid the Error 19 problem - it obviously won't fix any
problems with creating your initrd... ;-)

Thanks for the tip. It did fix the error 19 problem. I'm learning a lot here.

I'm now using the following:

        title Xen 3.0 / XenLinux 2.6
kernel /xen-3.0.gz dom0_mem=262144 root=/dev/mapper/group1-dom0slash ro console=tty0
        module /vmlinuz-2.6.12-xen root=/dev/mapper/group1-dom0slash
        module /initrd.img-xen-  root=/dev/mapper/group1-dom0slash

I also tried with:

        module /initrd.img-xen-

The kernel does load now, but it falls over during boot with an error that flashes past so quickly that I can't read it. I've tried videoing it using my phone but the quality is too low. I *think* it says something about failing to mount, and maybe initrd. Currently working on ways to capture the error message so that I can read it. If all else fails then I'll use a decent video camera tomorrow.



Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.