[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] xen3 with bind in domU - SOLVED

From: "Tom Eastep" <teastep@xxxxxxxxxxxxx>
On Tuesday 14 March 2006 09:28, Daniel Bauer wrote:
I've got a runnig xen host with "nothing" inside dom0 and some domU

1. domU: firewall and router (external and internal interface)
2. domU: webserver with bind (internal interface)
3. domU: mailserver (internal interface)

if I start a query at the domU bind from the inside of the network it
if I start the same query from the outside of the network then it
I'm sure that the firewall allowed this query, I'm using the same
iptables rules which worked on the 3 differnt real boxes.

Does anybody knows this problem?

I had problems with bind in domU until I arranged for the following to
executed in the domU when interface 'eth0' was brought up:

ethtool -K eth0 tx off

Before I applied that change, tcpdump showed that UDP packets from the
had invalid checksums.

Great this solved my problem, lot of thanks

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.