[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Cannot have eth0 in domU

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: cqfd <cqfd2c@xxxxxxxx>
  • Date: Sat, 25 Mar 2006 12:10:04 -0500 (EST)
  • Delivery-date: Mon, 27 Mar 2006 14:17:10 +0000
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.ca; h=Message-ID:Received:Date:From:Subject:To:MIME-Version:Content-Type:Content-Transfer-Encoding; b=Q08bZUOXgRI0TD9sZiB2gbtVSbBUz3MguRSMzS1BacL78hw24wpZyob6WyFna6fVufSUNDoPc9oc9o33bHWTKgFhBxo/nlgwyUwevWowhCQg3GtioKo2c6yYDPnJLSwo+9aK5qpCGB0uhzgJcoKmFGcJYaw/2+jY5hZBbWxMl5A= ;
  • List-id: Xen user discussion <xen-users.lists.xensource.com>


I am trying to run Xen 3 on FC5, but I cannot have the eth0 interface appear in domU.

I have 3 servers running FC3 and Xen 2 with various domUs since a year. Everything is fine on that front.

I took one of the server, upgraded it to FC5 and did the following:

- yum install xen kernel-xen0 kernel-xenU
- grub.conf contains
  title Fedora Core (2.6.15-1.2054_FC5xen0
  root (hd0,0)
  kernel /boot/xen.gz-2.6.15-1.2054_FC5
  module /boot/vmlinuz-2.6.15-1.2054_FC5xen0 root=LABEL=/ ro console=tty0 noscsi
  module /boot/initrd-2.6.15-1.2054_FC5xen0.img
- rebooted with the xen0 kernel
- kept the default xend-config.sxp to use bridging
- started xend
- copied a domU FC3 image from another server (tried also with a trustix image)
- mounted the FC3 image in loop fs and copied (cp -a) /lib/modules/2.6.15-1.2054_FC5xenU to it
- created a domU configuration file:
  kernel = "/boot/vmlinuz-2.6.15-1.2054_FC5xenU.img"
  memory = 128
  name = "test"
  vif = [ '' ]
  disk = [ 'file:/images/fc3,sda1,w' ]
  root = "/dev/sda1 ro"
  extra = "4"
- xm create -c test.conf
- everything in domU is fine except that eth0 is not seen:
  ifconfig eth0
  eth0: error fetching interface information: Device not found
- "ifconfig -a" shows lo and sit0 only
- on dom0:
   brctl show
   bridge name      bridge id              STP enabled      interfaces
   xenbr0               8000.feffffffffff      no                       peth0
- domU image contains valid ifcfg-eth0 configuration file
  I tried to add network configuration into the domU configuration file:
  and got the same results.
- I tried with and without a ramdisk image in the domU conf file (getting desperate here)
- no errors in domU dmesg or with "xen dmesg" on dom0

I really don't know where to go from here. I made several attempts with variations in config files but always got the same problem. Am I missing something obvious? Any suggestion as to what tools I can use to troubleshoot?
Any help would be greatly appreciated.

Thanks alot


Lèche-vitrine ou lèche-écran ? Yahoo! Magasinage.
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.