[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] network-route and vif-route setup help

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: "Md Mooktakim Ahmed" <mma@xxxxxxxxxxxxx>
  • Date: Tue, 28 Mar 2006 23:13:26 +0100 (BST)
  • Delivery-date: Tue, 28 Mar 2006 22:15:07 +0000
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

I just tried what you said below. I'm not sure if its working though. I tried 
one more time and still disconnected from the network. waiting for 1and1 to 
But i can access serial console.

So what i see is this, ifconfig says:
[root@cyclops ~]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:40:CA:80:5B:80
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::240:caff:fe80:5b80/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:23 Base address:0xe000

lo        Link encap:Local Loopback
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:48 errors:0 dropped:0 overruns:0 frame:0
          TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:4360 (4.2 KiB)  TX bytes:4360 (4.2 KiB)

vif1.0    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link
          RX packets:10 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:5 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:588 (588.0 b)  TX bytes:0 (0.0 b) is my main IP. vif1.0 seems to have been assigned the same ip.
which probably makes sense because of what ip r says:
[root@cyclops ~]# ip r dev vif1.0  scope link  src dev eth0  scope link
default via dev eth0

37.144 is my domU ip. not sure exactly whats going on. but it probably means 
vif1.0 is
connected on 144? no idea.

and what i have in my domU config:
vif = [ 'ip=' ]
ip = ""

the question is here do i use my isp's gateway? (10.*) the one for dom0?
OR do i use dom0 itself? since we are routing i should use dom0?
I tried both. the ifconfig and ip r output is the same.

and lastly i used centos for domU too. so my 
/etc/sysconfig/network-scripts/ifcfg-eth0 is:

Is everything correct here?
I will send another email detailing if it worked when my connection was 

Ralf Steenbock:

> I had the same problems with my new provider a few days ago. For me it
> is working when I set
> echo 1 >/proc/sys/net/ipv4/ip_forward
> echo 1 > /proc/sys/net/ipv4/conf/eth0/proxy_arp
> in /etc/xen/scripts/network-route. /etc/xen/scripts/vif-route is
> unchanged. domUs have to be configured with the public IPs you got from
> your provider like the following:
> vif = [ 'ip=your.public.domu.ip' ]
> ip="your.public.domu.ip"
> netmask="your.domu.net.mask"
> gateway="your.providers.gateway.ip"
> After restarting you should see a line like the following in the output
> of "ip r" in your dom0:
> your.public.domu.ip dev vif1  scope link  src your.public.dom0.ip
> I hope that I did not forget anything.
> Good luck
> Ralf

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.