[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] yet another networking question

  • To: xen-users <xen-users@xxxxxxxxxxxxxxxxxxx>
  • From: mbjohn@xxxxxxxx
  • Date: Thu, 30 Mar 2006 15:13:08 -0500 (EST)
  • Delivery-date: Thu, 30 Mar 2006 20:14:50 +0000
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Hello again --

First off, thank you to everyone who responded to my question regarding
the fsck problem we were seeing.  You guys were quick and helpful.  We now
have a working xen Virtual Machine.

Which brings me to my secondly...networking is ALMOST working on our VM,
but not quite.

I've looked at several different documents to help with the networking and
haven't had much success.  We are wanting to use VMs to use as
nameservers, radius servers, dhcp servers, etc., so they have to have an
ip address that the world can access.  I have tried several things.
I thought that adding:

nics = 1
dhcp = "off"
ip = "x.y.250.200" (where x and y != private address space)
netmask = ""
gateway = "x.y.250.129"
hostname = "vm03"

would make the appropriate magic happen.  However, after doing that, I
booted our VM and had no interface up at all.  I could do 'ifconfig eth0'
and it had no ip information.  If I did 'ifconfig eth0 up', it would come
up, but with nothing.  'ifup eth0' did not work.

Going back over the Xen Docs, it said that 'vif = [ '' ]' would make the
Right Thing(tm) happen, so I added that option, both with and without the
other options (ip, gateway, etc) and for some reason my virtual machine is
not picking up those options.

After that, I created /etc/sysconfig/network with this:

and /etc/sysconfig/network-scripts/ifcfg-eth0 with this:

After I added those, I was able to boot up and do 'ifup eth0' and voila!
I had eth0, it had the ip address, and I could ping other devices from my

So I thought I had a breakthrough.  However, there seems to be a couple of

1)  Name lookup does not work, from either my Dom0 or VM.
2)  I tried to run 'yum update'.  First go, because names didn't resolve,
I got a name lookup failure.  So, I added the name and ip address to
/etc/hosts.  After that, I get a 'no route to host' error.

Regarding number 2, I found some information about the 'no route to host'
error on the mailing list.  They suggested using the network-route and
vif-route scripts as opposed to network-bridge and vif-bridge.  I tried
that and still had no luck.

Our Domain0 is running Centos 4.2, as is our VM.  We're running the latest
version of Xen.

Thank you for your help!


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.