[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] yet another networking question

On Thu, 2006-03-30 at 15:13 -0500, mbjohn@xxxxxxxx wrote:
> I have tried several things.
> I thought that adding:
> nics = 1
> dhcp = "off"
> ip = "x.y.250.200" (where x and y != private address space)
> netmask = ""
> gateway = "x.y.250.129"
> hostname = "vm03"
> would make the appropriate magic happen.

I have not had much luck configuring domU IP interfaces this way.  I
prefer to just configure each the domU with a static MAC address (using
the 00:16:3e:xx:xx:xx IEEE range assigned to XenSource Inc), configure
DHCP service to assign static IP addresses base on the MAC address.
Then all you have to do is configure the domU's network interface using
it's own tools (run "system-config-network" on RHEL/Centos, or
"vi /etc/network/interfaces" on debian/ubuntu).

DHCP is a standard service for controlling IP addresses.  I see no
advantage to trying to set them in each domU's config file, especially
since it appears that all this really does is pass the info to the
kernel on the boot command line.  It's up to each distribution to
correctly interpret the command line parameter, and so far, I've only
seen it work on Debian Sarge.

> 2)  I tried to run 'yum update'.  First go, because names didn't resolve,
> I got a name lookup failure.  So, I added the name and ip address to
> /etc/hosts.  After that, I get a 'no route to host' error.

It sounds like you have a routing problem.  Fix dom0 first.  Run
'netstat -rn', make sure you have a default route and that you can ping
the assigned gateway.  If it fails, you might have configured the wrong
IP address, netmask or gateway IP, or you might have a physical network
problem (bad cable).

If you can ping the default gateway, then try pinging something beyond
that.  If that fails, you might need to check that your IP network is
being routed properly (check with your local network admin).  If you're
using RFC1918 private IP addresses (10.x.x.x, etc), make sure something
is doing NAT to hide them.

Also, make sure you've run 'ethtool -K eth0 tx off' (on both dom0 and
domU), or else it might just be corrupt packets causing your problem.

Patrick Wolfe  (pwolfe@xxxxxxxxxxxxxx)

Attachment: signature.asc
Description: This is a digitally signed message part

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.