[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] xen 3.0.2 DomU and ztdummy


I am trying to setup an asterisk Server in a DomU.

for the conferencing stuff I need a proper time and so i decided to use the 
ztdummy module from the zaptel drivers.
I set this up once with a SuSE 10.0 - and everything in that 
special-Novell-patched xen worked fine.

Now I threw that away and installed the latest 3.0.2 xen from source - on a 
clean SuSE 10.
In the Dom0 everything works fine - but thats not my intention.

When I setup all in the DomU and try to load the Module the following errors 

WARNING: Error inserting rtc 
(/lib/modules/ Input/output error
WARNING: Error inserting rtc 
(/lib/modules/ Input/output error
FATAL: Error inserting ztdummy (/lib/modules/ 
Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error running install command for ztdummy
 !!! error loading ztdummy module

dmesg tells me this:

Zapata Telephony Interface Registered on major 196
Zaptel Version: 1.2.5 Echo Canceller: KB1
rtc: IRQ 8 is not free.
rtc: IRQ 8 is not free.
ztdummy: Unknown symbol rtc_register
ztdummy: Unknown symbol rtc_unregister
ztdummy: Unknown symbol rtc_control
Registered tone zone 3 (Netherlands)

A guy I talked to, told me with his install (xen 3.0.1) it would work fine.

Is there a way to give access to the rtc to (multiple) DomU(s) ?
I can't really find some docs about this problem - it seems I am the only one 
with this prob.
I meanwhile now i have to switch the internal clock from 100 to 1000 Hz - but 
if i can't even load the ztdummy module I see no sense int tweaking around.

If anyone has an idea, or has already solved this - any help is welcome.
I read something about "pci-passthrough" in the archives - if this would help, 
how is it done ?



Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.