[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Re: Networking in an HVM domU - SOLVED

  • To: Xen <xen-users@xxxxxxxxxxxxxxxxxxx>
  • From: "David Goodlad" <dgoodlad@xxxxxxxxx>
  • Date: Thu, 20 Apr 2006 09:05:17 -0700
  • Delivery-date: Thu, 20 Apr 2006 09:05:57 -0700
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta; d=gmail.com; h=received:message-id:date:from:to:subject:mime-version:content-type:content-transfer-encoding:content-disposition; b=LYBpEefdBRV8GZI5x7F4vvL/A3ix2ti+KLuIfcSbuMFXw7g4YQPfiTdqgXPBltV0kgxiLY1z2nsds4CFtIqzREpHSwFMVy0hhtJLqdBJy6ukVAYENCi3Z0vue7TTjZJ1UzuRP2FFeAI4URYX60+RbhNNl2ZQGMdV0zi3qcCj2Wg=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

On 4/18/06, David Goodlad <dgoodlad@xxxxxxxxx> wrote:
> Hi all
> I can't seem to get networking to function at all in hvm/vmx guests.
> I've tried both winxp and linux guests, and neither can get any
> traffic through their network devices.  The device _is_ detected as a
> pcnet32 card, which is fine, but I see 0 packets going through, even
> at the vifx.0 virtual device on the dom0 side.
> Regular (modified, non-hvm) domU guests work without a problem, so
> it's not my network scripts that are broken.  It seems the emulated
> device just isn't sending/receiving any packets.

So that anyone reading this in the future, I managed to solve this
problem.  I realized that since qemu needs the tun/tap driver, I might
need it for hvm-based guests too.  It's odd that xen doesn't complain
one bit that the driver is unavailable, though.

In any case, a simple 'modprobe tun' solved this issue for me!


Dave Goodlad
dgoodlad@xxxxxxxxx or dave@xxxxxxxxxx

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.