[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] read only disk option in domUs

list user wrote:
Hi all,

Successfully running a built from source xen 3.0.2-2 & linux 2.6.16 on
fedora 4 with lvm.

I'm trying to share a read only /usr across multiple domU's.

Logical volume "/dev/vg0/usr" is read only.  Within the domU's fstab
/usr is "ro".  Here is the disk option from the domU definition.

disk = [ 'phy:vg0/fc4,hda1,w' ,
         'phy:vg0/usr,hda2,r' ,
         'phy:vg0/swap,hda3,w' ]

This fails with an unable to write block error.

Now if the vg0/usr volume is specified with 'w' it works without
complaint until I try to use it in a different domU.  Then the complaint
is that it is already in use in another guest domain.

Q 1: is inability to specify a phy: as read only a bug?
Q 2: what is the proper way to share/use a read only volume among domU's?

Following up on the resolution:

I tried various combinations of ro/rw at different levels of the filesystem hierarchy from lvm -> xen domU -> fstab using ext2 & ext3.

The only thing that worked for me 'read-only' was "ext2" formatting.

That said, the other domU's now *happily* share /usr.


Thanks for any help,
Mike Wright

Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.