[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Problem with eth0 with a Debian DomU on Fedora Core 5


A lot of people seem to have had problems running DomU's that are not
FC5 on FC5 Dom0's, the issue being that etho doesn't appear for the DomU
machine (I have read a lot of list archives this week...) -- I have this
problem when I boot a debian etch on FC5 (I have a FC5 DomU working
without a problem):

  Setting up networking...done.
  Setting up IP spoofing protection: rp_filter.
  Configuring network interfaces...SIOCSIFADDR: No such device
  eth0: ERROR while getting interface flags: No such device
  SIOCSIFNETMASK: No such device
  SIOCSIFBRDADDR: No such device
  eth0: ERROR while getting interface flags: No such device
  eth0: ERROR while getting interface flags: No such device
  Failed to bring up eth0.

And after it's booted there is only the loopback interface:

  # ifconfig         
  lo        Link encap:Local Loopback  
            inet addr:  Mask:
            UP LOOPBACK RUNNING  MTU:16436  Metric:1
            RX packets:0 errors:0 dropped:0 overruns:0 frame:0
            TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
            collisions:0 txqueuelen:0 
            RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

The answer that seems to have worked for FC4 guests on FC5 was in this

  Subject:      Re: Device eth0 does not seem to be present
  From:         Phil Evans <xenmail@xxxxxxxxxxxx>
  Date:         Sun, 23 Apr 2006 04:57:08 +0100

  Are you using the stock FC5 Xen kernels? If so, you will need to add the 
  following line to the /etc/modprobe.conf files in your domU:

  alias eth0 xennet

However I haven't had any luck with this on debian, I tried adding this
to /etc/modutils/aliases and /etc/modutils/actions and /etc/modules
since /etc/modprobe.conf is automatically generated on debian, but no
luck with any of them.

I tried loading the module manually:

  # /sbin/modprobe xennet
  modprobe: Can't open dependencies file 
/lib/modules/2.6.16-1.2096_FC5xenU/modules.dep (No such file or directory)

This doesn't work since /lib/modules/ is empty, and I found this in the

  Subject:      Re: eth0 not showing up in guest domains
  From:         Jeremy Katz <katzj@xxxxxxxxxx>
  Date:         Wed, 22 Feb 2006 00:31:36 -0500

  The guest kernel is built with a modular xennet, so you'll need to have
  the modules in the filesystem image as well.

So I tried mounting the disk in Dom0 and copying across the files:

  # mount -o loop /usr/local/xen/sarge /media/sarge
  # cp -a /lib/modules/2.6.16-1.2096_FC5xenU/ /media/sarge/lib/modules/

When I then boot the DomU I still get the same errors as above but I get
a different error when trying to load the xennet module:

 # /sbin/modprobe xennet
 Note: /etc/modules.conf is more recent than
 modprobe: QM_MODULES: Function not implemented

 modprobe: QM_MODULES: Function not implemented

 modprobe: Can't locate module xennet
Does anyone have any suggestions?



Chris Croome                               <chris@xxxxxxxxxxxxxxxxxxx>
web design                             http://www.webarchitects.co.uk/ 
web content management                               http://mkdoc.com/   

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.