[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] VNC, framebuffer at boot

Henning Sprang wrote:
On 2/1/07, Jim <jim@xxxxxxxxxxxxxxxxxx> wrote:
Rakotomandimby Mihamina wrote:
> Hi,
> I try to boot some Ubuntu live CD or Mandriva Live CD in full virtualization
> mode (domU, then), but their boot prompt are mostly "framebuffered".
> When I connect to the domU through VNC, I see nothing but a black window.
> What workaround should be used?
> Thank you.
Try a different distro.  I found that booting Ubuntu in SuSE 10.2
produced an unreadable display, however it looked fine booting from a
FC6 system.

While I have some of the major distributions at hand here and will try
it later, a lot of people won't want to change their main distribution
because of this.
I agree, that's not the ideal way of fixing the problem, but it worked for me.

So, maybe it can be solved another way, therefore some questions:
- Did you use the same domU config files on both?
- which Xen packages and versions did you use (as well on the failing
system as on the successful system).
In both cases I used the Xen packages that came with the OS. The domU config files were similar, but not identical. The differences were in the disk layout, which I don't think would make a difference. No differences in the graphical settings.
- was the display "unreadable" or actually just blank? (my symptoms
were that it was just blank)
Unreadable. Text was just a smear or only parts of the letters showed up in one case. Blank in another. I booting multiple distros to see what would happen. The set was Ubuntu, SuSE 93, Centos 4.4, Debian sarge and FC6. I dont' recall the details of each at this time, however.

I can't  tell anymore, on which distributions I had the problems, I am
playing around with quite some of them, but i will see what fedora


Keep us posted.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.