[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] SLES10 Error: (9, 'Bad file descriptor')

On 13 Feb 2007 at 0:08, Christian wrote:

> Hi users,
> set up a host with SLES10 x86_64.
> Created a domU(sles10-64) with SLES10 x86_64 too, works (used kernel
> from dom0)
> Created a domU(sles10) with SLES i586, works with kernel from dom0
> but when I try to use "i586" kernel for this "sles10" and try to boot,
> I get: Error: (9, 'Bad file descriptor')

AFAIK, the EMT64 media of SLES10 only contains a 64bit XEN Kernel. You cannot 
"any kernel", unless using HVM mode.


> I googled around and found to try "mkinitrd -s off" for building
> initrd-modue but with no succes.
> Other option was to use mkinitramfs instead, but SLES10 does not have it. :(
> Is it possible to run i586 guest with a i586 kernel on x86_64 Host ??
> Target is to be able to build "i586" RPM's with guest and this does not
> work while the i586 guest uses the x86_64 kernel of dom0. (uname -m)
> x86_64 :(
> I tried to use bootloader, to load initrd from inside the guest, but
> with same error.
> And help would be apreciated.
> Many thanks
> Chris
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-users

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.