[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] xm migrate --live never returns

  • To: <xen-users@xxxxxxxxxxxxxxxxxxx>
  • From: "Kraska, Joe A \(US SSA\)" <joe.kraska@xxxxxxxxxxxxxx>
  • Date: Tue, 20 Feb 2007 14:28:16 -0800
  • Delivery-date: Tue, 20 Feb 2007 14:27:50 -0800
  • List-id: Xen user discussion <xen-users.lists.xensource.com>
  • Thread-index: AcdVPmqpppvyu9E3Tb+R4SBigVaOhQ==
  • Thread-topic: xm migrate --live never returns

I have two OpenSuse 10.2 boxen running on Del 1955 blades (Intel Woodcrest 5160)

and VT enabled in the BIOS. OpenSuse 10.2 uses xen-pae-3.0.3-11775-20.


Each box is running a dom0 (with the appropriate configuration for Xend to enable



I successfully execute:


% xm migrate –live <domid> <dest-ip>


The domU live-migrates to the other dom0 and arrives in a healthy state.

When I attempt the operation in reverse, the command hangs and never



On the sending dom0, the machine shows a name of:




On the receiving dom0, the machine shows a state of –p----


What’s weird about this situation is that just yesterday I ran a ping pong test on the

two systems and watched them migrate back and forth every 19.1 seconds for like

20 minutes.


I interrupted the programs, twiddled a bit, and managed to crash xend on one of the

hosts. xend wouldn’t cleanup properly with “service xend restart”, so I rebooted the

host entirely.


No configuration changes have been made since the period that it worked.


This post from the archive in 2005 seems to be similar to what I am experiencing:




Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.