[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] SWAP on domUs is not mounted.

  • To: kanour-xen <xen@xxxxxxxxxx>
  • From: "Stephen Morris" <stchmorris@xxxxxxxxx>
  • Date: Sun, 25 Feb 2007 15:58:04 -0800
  • Cc: xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Sun, 25 Feb 2007 15:57:21 -0800
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:to:subject:cc:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; b=pcCmkwMghe+WT1qKr0YVTYneeFGryIHmE3xpZUvqeo9z9lYlazkgg1laEHOpkWpzp/IZWpSFuLdBYPcGPeFxRfmaG5wyVF0iN17EL4oK0xj0K8hOq7+KTxxwqdYf2cCh2rC6/qyLLbGRCZpdsWc7XXaOJqzBao3M8N0jPNt9yA4=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

On 2/25/07, kanour-xen <xen@xxxxxxxxxx> wrote:
My SWAP on all domUs is not working.

On dom0 I have logical volume (LVM) created and formated for swap. I can
enable this volume under dom0 as a swap (tested).
On domUs I am unable to enable it. I have swap support compiled in kernel.
My fstab is properly configured.

Can someone advice?


Xen-users mailing list

Hi Jiri,

I had a similar problem, but was using a primary swap partition for
swap. What worked for me was to use an interactive "xm block-attach .
. ." command - the
arguments were similar to those used in the "disk" command (for the
swap) in the configuration file. The swap file worked on the next domU
boot and has worked every time since. I haven't yet discovered where
this configuration is stored.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.