[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] SWAP on domUs is not mounted.

On Sun, 25 Feb 2007 16:09:14 -0800 (PST), Tom Brown <tbrown@xxxxxxxxxxxxx> 
> On Sun, 25 Feb 2007, Stephen Morris wrote:
>> On 2/25/07, kanour-xen <xen@xxxxxxxxxx> wrote:
>>>  Hi.
>>>  My SWAP on all domUs is not working.
>>>  On dom0 I have logical volume (LVM) created and formated for swap. I
> can
>>>  enable this volume under dom0 as a swap (tested).
>>>  On domUs I am unable to enable it. I have swap support compiled in
> kernel.
>>>  My fstab is properly configured.
>>>  Can someone advice?
>>>  Jiri
>>>  _______________________________________________
>>>  Xen-users mailing list
>>>  Xen-users@xxxxxxxxxxxxxxxxxxx
>>>  http://lists.xensource.com/xen-users
>> Hi Jiri,
>> I had a similar problem, but was using a primary swap partition for
>> swap. What worked for me was to use an interactive "xm block-attach .
>> . ." command - the
>> arguments were similar to those used in the "disk" command (for the
>> swap) in the configuration file. The swap file worked on the next domU
>> boot and has worked every time since. I haven't yet discovered where
>> this configuration is stored.
> Xen seems (i'm NOT a developer) to have a storage system/daemon for config
> info like this... there should be a xenstored process in dom0 which
> handles it. You can query it via the xenstore* commands. And of
> block-attach is helping, then block-list may provide usefull info too.
>    xm block-list DOMID
> ... but I'm not sure if it gets its info from xenstore or parts of it come
> from the hypervisor.
> -Tom
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-users

Hi Guys. Still nothing. I have tried everything.
But I found out that /dev/hda1 or /dev/hda2 don't exist in domU.
Any advice?

Just make things clear:
- dom0 amd64 debian etch
- domU amd64 debian etch
- domU disk config:
- !!!! domU does not have /dev/hda1 /dev/hda2 in /dev directory 

Some other commands on domU (monit1):
/dev/sda1       /       ext3    defaults        1       2
/dev/sda2       none    swap    sw      0       0
devpts          /dev/pts        devpts  gid=5,mode=620  0       0
none    /dev/shm        tmpfs   defaults        0       0

monit1:~# cat /proc/partitions
major minor  #blocks  name

   3     2     512000 hda2
   3     1    2097152 hda1

monit1:~# mkswap /dev/hda2
/dev/hda2: No such file or directory

Any advice?

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.