[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Mouse cursor problems in Windows DomU after installing ATI-driver fglrx to X11

  • To: <xen-users@xxxxxxxxxxxxxxxxxxx>
  • From: "Artur Linhart - Linux communication" <AL.LINUX@xxxxxxxxxxx>
  • Date: Tue, 3 Apr 2007 07:54:42 +0200
  • Delivery-date: Mon, 02 Apr 2007 22:53:56 -0700
  • List-id: Xen user discussion <xen-users.lists.xensource.com>
  • Thread-index: Acd1tJAK6E6OaQdZSwq1Q0b5imjltw==



            I run Xen on Ubuntu 6.06 with Gnome desktop. I can start Windows as DomU without problems, everything works fine (w2k server32 bit or w2k3 server 64 bit).

            Because I use the notebook HP nx9420 which has a wide screen, I installed into X11 the driver fglrx which supports the given resolution mode 1680x1050.

            Now, with the new driver The Gnome desktop works good on the new (full) resolution, but after I start the Windows DomU (does not matter which), after the boot the cursor appears there on the central position on the screen – so it looks normally, but after I’ve clicked into the “Windows” window and moved by the mouse, the mouse cursor disappeared and is invisible. Windows detect still the mouse as normal PS/2 compatible mouse, but the mouse is not visible in DomU. After I press Ctrl-Alt the normal mouse appears again in X11, but in Windows – nothing. If I change the resolution to the original one with the new driver, this effect is still here. If I use the old xorg.conf for the desktop, the mouse behaves correctly.

            Ok, I thought this could be the problem of the driver also, but – I’ve figured out the mouse cursor not only disappeared, it is also moved to the bottom right corner – if I click on the right mouse button there apperars in windows desktop the menu in the bottom right corner – no matter how I move by the mouse, the menu comes still in the bottom right corner, like the movement of the mouse would be ignored. So maybe the cursor is not visible, because it is just “out of the desktop” and hits desktop only by 1 point in the bottom right corner.


            I use normally touchpad, by I’ve tried also the mouse, I’ve tried the drivers for synaptics directly or the general mouse driver, no change.


            So I guess – if it is really so the cursor is visible, but does not react on movements – this could be rather the problem of Xen and not of the driver, because I think the graphic card driver should not influence the movement of the mouse (only the cursor visualization, if even something)...


            Can anyone help me with this issue? Sure, I can also live with the old driver, but then everything on the desktop is a little bit deformed, because the 1280 points are spread to 1650, so everything is deformed... And I thik generally there should be “no reason” why the Dom0 graphic driver should influence the mouse movements in DomU


            Ay help or advice would be appreciated.


                        Greetings, Archie.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.