[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Harddisk support not working


after experimenting for days with xen I was finally able to narrow down
why my xen setup is not working properly. When I add a harddisk to the
guest system the guest system slows down so much that it becomes
impossible to boot. In my hvm testsystem the guest system is a knoppix
cd. When booting from the cd without having a harddisk in the guest
system everything works perfectly. But as soon as I add a harddisk 
booting slows down as soon as the quemu haddisk and cd have been detected.
When the the knoppix system actually boots. I read the following

"Accessing KNOPPIX DVD at /dev/hdb..."
" Found primary compresse KNOPPIX image at /cdrom/KNOPPIX/KNOPPIX"

Now it takes about 10!!! MINUTES for the next message to appear:
" Found additional compresse KNOPPIX image at /cdrom/KNOPPIX/KNOPPIX2"

Then I see quite often the following arrow message:
"hdb: DSC timeout"

After about an hour and tones of those error messages the system still
is not done booting. The wired thing is that knoppix does not even touch
the harddisk when booting.

This is my .xm file with the working and the not working config:

    kernel = "/usr/lib/xen-default/boot/hvmloader"
    memory = 512
    name = "cd"

    #does not work:
    #disk = [ 'phy:/dev/sdb,ioemu:hda,w', 
    #   'file:/mnt/xen-images/knoppix52.img,ioemu:hdb:cdrom,r']
    # also tried it without ioemu and to add a lvm partiton
    #works perfectly:
    disk = [ 'file:/mnt/xen-images/knoppix52.img,ioemu:hdb:cdrom,r']

    vif = [ 'type=ioemu, bridge=xenbr0' ]
    device_model = '/usr/lib/xen-default/bin/qemu-dm'

My host system:
Tried debian testing; now using unstable
I'm using the xen-hypervisor-3.0.3-1-i386-pae package from the
distribution (I also tried the unstable packages but I could not get 
them to work)
The system is a core duo 1 with 2 GB ram

I also tryed a windows system. It took all night to install it. It is
working normally but extreamely (unusably) slow. I also tryed to install
a debian system from an installation cd. But the installation took so
long that I gave up after a few houres.

I've googled for a while. The only similar case I could find was
somebody reporting the same problem when using more then one haddisks.
But no solution for the problem.

I really appreciate your help as I've spent houres trying to setup xen.
Thank you very much!

Best regards,

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.