[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] DomU crash on connecting to the console (Urgent)

Hi all,
Here are the things that I tried to do:
Created a volume group:
        # vgcreate /dev/sdd/ VG
        # lvcreate -L4096M -n myvmdisk1 VG
Created a filesystem, mounted and populated it.
         # mkfs -t ext3 /dev/VG/myvmdisk1
        # mount /dev/VG/myvmdisk1 /mnt
        # cp -ax / /mnt
        # umount /mnt
Now in my configuration file I did
        disk = [ 'phy:VG/myvmdisk1,sdd,w' ]
I tried to create the VM through xm command:
        xm create -c xmexample  vmid=4 pci=0x:0x.0 ip=x.x.x.x netmask=x.x.x.x dhcp=off dns=<name> gateway=x.x.x.x                hostname=<hostname>

The DomU creation goes fine and it shows on the xm list output.
But when I try to connect to the console it panic:
        VFS: Cannot open root device "sdd" or unknown-block(2,0)
        Please append a correct "root=" boot option
        Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0)
And the DomU crashes.

Can anyone suggest me what might be the problem?
Anticipating a quick reply.

Thanks and regards

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.