[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Can't get the bridge setup (no veth0/peth0/xenbr0)


I'm new to xen 3. I just setup xen a few days ago but it seems impossible to the get the networking going. I have the following setup:

1 debian etch server with 5 IP addresses (x.x.x.80 - x.x.x.84) currently setup as eth0 (.80) till eth0:4 (.84). I want to keep eth0 (.80) and eth0:1 (.81) as IP addresses for dom0 and give each virtual machine 1 IP (starting with .82).

From what I understand you should get, when you start the xen daemon a veth0, eth0 and peth0 device which are somehow connected to a bridge, xenbr0. I don't get any (in my xend-config.sxp I have both (network-script network-bridge) and (vif-script vif-bridge) enabled). When I run the network-bridge script manually I get an error saying I don't have a veth0 device (when I run `ip link', it is there though). When I run the network-bridge script with the following options: vifnum=0 netdev=eth0:2, it does setup a bridge device, I see veth0 + xenbr0 in my ifconfig and I get an eth0 device in my virtual machine, but the networking itself doesn't work.

I'm not sure what the problem is, so hopefully someone here can help me. Thnx. 


Jochem van Leeuwen

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.