[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] can't start RH4 domU on RH5 dom0 Error: (22, 'Invalid argument')

I went through the process of getting CentOS 4.5 installed in the last 2 days, it's fresh on my mind what you need to do. Comments below.

Nico Kadel-Garcia wrote:
Andrey Dmitriev wrote:
Modified my config file as

[root@mt-mail1 xen]# more /etc/xen/scalix2
#kernel = "/boot/vmlinuz"
#ramdisk = "/boot/initrd.img"

memory = 512
name   = "hating-xen"

vif    = ['ip = "", bridge=xenbr0']

disk   = [

BTW, it boots fine with vmlinuz, which is a CentOS xen kernel. However, it goes right into some installation, which I can't seem to get out of. Does it really matter which kernel I run? And how can I avoid the installation menus.
You are using an initrd image to match the CentOS xen kernel? The initrd image that I am using (for install) is SPECIFIC to installation, i.e. it has different stuff than the initrd that is installed. The vmlinuz kernel here http://mirror.centos.org/centos/4.5/os/i386/images/xen/ is identical to what is installed once CentOS 4.5 is installed.

I also just discovered that I boot fine with vmlinuz-2.6.18-8.1.6.el5xen, but it pukes on mounting file systems.
What initrd are you using at that point? This could be the problem. You will want kernel modules to match your kernel... and you get that by matching the initrd.img to the vmlinuz.

I can't sort out what you are doing below because the replies where a mess and not properly threaded.
[root@mt-mail1 ~]# xm create /dev/null
kernel=/mnt/software/vmlinuz-2.6.9-55.ELxenU name=ramdisk vcpus=2
memory=412 root=/dev/ram

disk   = ['file:/mnt/software/RHEL4-U5-x86_64-ES-disc1.iso,cdrom,r',
          'phy:XEN/XEN-scalixroot ,sda1,w'

cdrom = "/mnt/software/RHEL4-U5-x86_64-ES-disc1.iso"
root   = "/dev/sda1 "
no CD
You need to read XenSource User Guide even if you only use the open source stuff possibly from your dom0 distro. The reason is, it tells you that RHEL4/CentOS4 can NOT be installed off of a CD or iso image. You must install from the network, NFS worked for me.

no sda image
I found that The CentOS 4.5 kernel (and I'm sure the RHEL4u5 kernel) would not work with "sda" style front end names. You seem to have to use "xvda."

no xvda1 image
Also the CentOS 4.5 kernel does not understand an "xvda1" partition popping up without the stuff that an entire disk would give it like a partition table. So you have to have a full disk image. (I could be wrong, you might have found something there that works.)

This page is good for reference, but assumes you have pygrub which I don't with a dom0 of SLES10SP1:

Here is my config for INSTALL purposes:
name = "centos"
memory = "256"
disk = [ 'file:/root/cent/cent-xvda.img,xvda,w' ]
vif = [ 'bridge=xenbr1,mac=00:16:3E:0A:95:28' ]
on_reboot = 'destroy'
on_crash = 'destroy'
vfb = [ 'type=vnc' ]
kernel = "/root/cent/vmlinuz-boot"
ramdisk = "/root/cent/initrd-boot"

After the install I modify the config (so I don't get taken into the install again!):
name = "centos"
memory = "256"
disk = [ 'file:/root/cent/cent-xvda.img,xvda,w' ]
vif = [ 'bridge=xenbr1,mac=00:16:3E:0A:95:28' ]
on_reboot = 'restart'
on_crash = 'destroy'
vfb = [ 'type=vnc' ]
kernel = "/root/cent/vmlinuz"
ramdisk = "/root/cent/initrd"
extra = "ro root=/dev/xvda1"

I'm now using the extra parameter and an initrd from INSIDE the installed image (in xvda1:/boot/). This was tricky to grab from outside the image, and I had to without pygrub. SLES/SLED have stopped shipping pygrub because it is broken on their platform, they use domUloader for now. So I got it out by booting like I was going to install CentOS again, but then I used this in my 'install' config for one more boot:

 extra = "rescue"

This allowed me to go into "rescue mode" and with networking and I did something like this:

cd /mnt/sysimage/boot
rsync vmlinuz-2.6.9-55.ELxenU initrd-2.6.9-55.ELxenU.img root@dom0:.

All this cleverness because. 1... pygrub is not there on SLES. 2.... I couldn't find a boot loader that would work without completely upgrading to xensource's xen. 3... I didn't know how to loop back mount the partition since it was buried in an entire disk image. 4. I couldn't use individual images per partition, because the kernel seems old and not understanding partitions without a parition table.

Hope this helps you...  and maybe others.
-Scott Serr

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.