[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Xen networking problem


I've been googling around for several days now, but with no luck. I'm hoping someone here might be able to help me out...

I've installed and run Xen 3.0.4 (I need this specific version) with no problem, and the guests run smoothly; the only problem is that I have never been able to get the guests to ping the host (Dom0), or vice versa. I cannot access the internet from the guests, but it works fine on Dom0.

I have only one NIC on Dom0 (eth0) that connects to the internet. Right now I'm just trying to get the guests and Dom0 to recognize each other, let alone guests' internet access.

I've tried network-bridge, network-nat, network-route, and even some custom scripts such as network-private (http://lists.xensource.com/archives/html/xen-users/2006-09/msg00925.html) and network-virtual (http://en.opensuse.org/Xen3_and_a_Virtual_Network), with no success. I've tried all I could, but here's one thing I believe is the problem. When I run ifconfig on Dom0, I see this on the guest's vif:

vif2.0    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF
          UP BROADCAST NOARP  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

As you can see, I don't see a "RUNNING" flag on guests' vifs.
Can anyone please help me out? I'm completely lost here.

If it helps, I'm running Ubuntu 7.04, and I'm experimenting with an HVM guest (Windows XP).


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.