[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Reassuming Xen 3.1 boot problems. Not work yet.


At the end, my situation is:

I try to use a prebuilded XEN version and Source version but the problem is still the same.

Without make initrd i receive this error:

"VFS: Cannot open root device "hda5" or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)"

ok....I try to create a initrd like this: mkinitrd -v -f --with=aacraid --with=sd_mod --with=scsi_mod -o /boot/initrd-2.6.18-xen.img -k 2.6.18-xen

Now seems to be XEN start but after memory message and little count down I received this error:

"can't find /mnt in /etc/fstab. ERROR: no /sbin/init found on rootdev (or not mounted!). Trouble ahead."

Then I have kernel panic and system restart.

So I check ext3 options and I look that is compiled like a module!! I try now to compile this one built-in. I use this procedure:

make linux-2.6-xen-config CONFIGMODE=menuconfig

i select ext3 compiled built-in...no like a module...

make linux-2.6-xen-build
make linux-2.6-xen-install

config file have EXT3 options = y now. vmlinuz for xen is changed, xen-3.1.gz no...

I still have the same previous error about /mnt and init!! This is my config files:

Slackware12: http://doxspace.altervista.org/config-huge-

XEN3.1: http://doxspace.altervista.org/config-2.6.18-xen

I think continue to generate a bad mkinitrd...You can say to me if my mkinitrd creation procedure is correctly? I must copy some others file in /boot/initrd-tree dir and re-create initrd?

I have tried all the roads… I don't know more where to break the head...ghghgh....


Best Regards.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.