[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] No eth0 device found in domU

Hi Luc,

On Wed, Sep 26, 2007 at 12:51:21PM -0400, Boudreau Luc wrote:
> See this : vif = [ '' ]
> That's a bad sign. "RTFM" as they say. 
> http://bits.xensource.com/Xen/docs/user.pdf

don't know what you try to say but I read the documentation carefully.
Probably you noticed that I supplied no MAC address and assumed that udev
creates eth1, eth2, ... instead of eth0. This is *not* true! No ethernet
at all is created in domU!

I tested various settings with OpenSuse's 3.0.3 rpms (including a fixed
MAC) and always failed! I compiled that's why Xen 3.1 (is this a stable
version? http://xen.xensource.com/ provides a link to 3.0 in "Get
Started with Xen!", the 3.1 source doesn't contain a changelog and its
Readme mentions only 3.0, also a FAQ(?) didn't mentioned 3.1 as released

Version 3.1 was also funny: My dom0 network did no longer worked (even
without a domU). The output of ifconfig and route looked good to me (I
also deactivated the firewall for tests), nevertheless I was not able
to resolve it. Doesn't Xen bridging also initiates connections between
eth0 and vif0.0? How can I check these?

After switching from bridge setup to NAT it worked well! So my problem
is now solved.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.