[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] No eth0 device found in domU

On Thu, Sep 27, 2007 at 08:53:04AM +0100, Fischer, Anna wrote:
> > I tried already a long time to enable network in my domU but 
> > I always fail with:
> > 
> > # ifconfig eth0 up
> > SIOCSIFADDR: No such device
> > SIOCGIFFLAGS: No such device
> > 
> > Do I need to load a kernel module?
> Do you have the Xen frontend network driver (xennet) installed and
> properly loaded on your domU system?
> > Network related domU kernel messages:
> > XENBUS: Device with no driver: device/vif/0
> This usually indicates that something with xennet is wrong...

Ah, didn't know this ...

I tried to install Debian using the network installer image containing a
kernel and an initrd. Because I didn't know whether I need to have kernel
modules in the Debian domU initrd I copied /lib/modules/2.6.18-xen/ from
OpenSuse 10.2 (dom0) into the initrd.

(Now I think I understand that I have to provide each domU software
modules such as ext2, ext3, ... and a few XEN specific modules such as
xennet but no modules for raw hardware access (usb-ohci, eth drivers ...),
right? Is this documented somewhere?)

I did this step (extenting initrd) multiple times (using:
 # mkdir initrd
 # cat ../debian-installer/i386/initrd | cpio --extract --make-directories
 # cp -r /lib/modules/2.6.18-xen/ lib/modules/
 # find | cpio -o -H newc | gzip -9 > ../initrd.gz
) so I really doubt that I did something wrong.

Exactly the same steps worked with Xen 3.1 (at least after switching to
NAT instead of bridge as my network was completely inaccessible with Xen

Sorry, I don't want to reinstall the Xen 3.0 RPMs as I have it currently
working but maybe OpenSuse RPMs are not working? It is unlikely as I
searched for similar trouble without success.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.