[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Fail SATA with Xen 3.x on Different Motherboards


I am unable to boot Xen 3.x (tried 3.0.3, 3.0.4, and 3.1) on two different motherboards running Debian 4.0. I've tried Debian packages of Xen 3.0.3 and 3.1, as well as compiling custom kernels. All resulted in "qc timeout" on the SATA drives. Debian's stock 2.6.18 kernel works fine though, so it's not a driver issue. My custom 2.6.18 kernel without Xen also boots fine on both servers.

Motherboard #1: SuperMicro PDSMU w/ Xeon 3060
SATA: onboard ICH7R SATA, AHCI enabled

ahci 0000:00:1f.2: AHCI 0001.0100 32 slots 4 ports 3 Gbps 0xf impl SATA mode
ahci 0000:00:1f.2: flags: 64bit ncq pm led clo pio slum part
ata1: SATA max UDMA/133 cmd 0xD103A500 ctl 0x0 bmdma 0x0 irq 11
ata2: SATA max UDMA/133 cmd 0xD103A580 ctl 0x0 bmdma 0x0 irq 11
ata3: SATA max UDMA/133 cmd 0xD103A600 ctl 0x0 bmdma 0x0 irq 11
ata4: SATA max UDMA/133 cmd 0xD103A680 ctl 0x0 bmdma 0x0 irq 11
scsi0 : ahci
ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
ata1.00: qc timeout (cmd 0xec)                          <------------- Problem
ata1.00: failed to IDENTIFY (I/O error, err_mask=0x104)
ata1: port is slow to respond, please be patient
ata1: port failed to respond (30 secs)
ata1: COMRESET failed (device not ready)
ata1: hardreset failed, retrying in 5 secs

Motherboard #2: SuperMicro X7DBR-E w/ Xeon Woodcrest 5148
SATA: onboard ESB2 SATA, AHCI disabled

scsi0 : ata_piix
ata1.00: qc timeout (cmd 0xec) <------------- Same Problem
ata1.00: failed to IDENTIFY (I/O error, err_mask=0x104)

Someone else reported in June the same problem on Asus P5B Delux. It was tagged as possible ACPI bug. Prior to that, another report in June 2006. It seems to be spreading to more motherboard type / brand, particularly the new ones.

Has anyone else seen this?

Andy Lee

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.