[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Why is the first domU created with domid = 2 instead of 1

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: "Haifeng He" <hehaifeng2nd@xxxxxxxxx>
  • Date: Fri, 2 Nov 2007 15:45:14 -0700
  • Delivery-date: Fri, 02 Nov 2007 15:45:56 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:to:subject:mime-version:content-type:content-transfer-encoding:content-disposition; b=NoAoAaPP3uzFtZaEtrtG0uVJCRRB+ctZQRM7rpK14W33oisCvgUvgfbq3QwfphOGho/h38+ramQTCHy//5ExgdDFMH44d4waVktgvPWg9DXQRZwcW5+xkWVpqJmft4hmSdrOHdQLqOiU7Ppa5IzhYcspxSNwudCTGZ16UwAHjIo=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>


I installed Xen(3.0.3) on Debian and created a guest OS kernel using
I can create domU successfully but I noticed that the domid I got for
the first domU
created is always 2, instead of 1 (dom0 has id 0). What's the reason for that?

I tried to trace the domain creating process and noticed that Dom0 does
try to create a domain with id 1 first but somehow it does domain creating
again and create domain with id = 2.

And one more weired thing, after I quit from domU, domU does not terminate
completely, i.e., it still appears when I run "xm list". I have to use
"xm destroy 2"
to stop it manually. What could the reason? Are these two problems related?

Here is my xen.cfg looks like.

kernel = "/boot/vmlinuz-2.6-xenU"
memory = 16
name = "domU"
vif = [ '' ]
dhcp = "dhcp"
disk = ['file:/xen/guest/domU.img,hda,w']
root = "/dev/hda ro"



Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.