[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Hanging utilities that read /proc

Today I experienced a hanging dom0 and domU. Applications that tried to access
/proc, such as ps, ifconfig, lvdisplay, mdadm all hung after displaying between 
and ten lines of output. 'free' worked and didn't output anything weird. Apache
was running in domU and also didn't respond.

This occurred in both dom0 as well as domU. After some time googling and
trying to analyze the situation, we wanted the server back so tried rebooting
domU. This didn't help so I rebooted dom0 as well but the problem persisted.

I needed to look at something else and looked at the box a couple of hours 
later. The problem now didn't occur anymore. I could execute all commands 
without hanging.

This log file shows errors from the snmpd daemon. Every 30 secs, a repetition
of the three lines:

Nov  6 09:41:45 alpha snmpd[2203]: netsnmp_assert index == tmp failed
                                   if-mib/data_access/i <<snip>>
Nov  6 09:41:45 alpha snmpd[2203]: netsnmp_assert __extension__ ({ size_t
                                   __s1_len, __s2_l <<snip>>
Nov  6 09:41:45 alpha snmpd[2203]: error on subcontainer 'ia_addr'              
                     insert (-1)
Nov  6 09:41:45 alpha last message repeated 5 times

Funny enough, logs show no gaps.

This is all on a Dell Poweredge 860, running CentOS 5.0, with kernel
version 2.6.18-8.1.6.el5xen.

Any ideas?


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.